CVE-2026-80204: Grav before 1.0.18 Authentication Bypass via Scoped API Key
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.18 does not apply the API-key scope cap in the injectSecurityTab() function of BlueprintController when deciding whether a page's security/permissions blueprint section is editable. Because the function performs raw isSuperAdmin()/hasPermission() checks without a request parameter, it cannot enforce scopeAllows(). A caller holding a scoped API key may therefore see (and potentially edit) page permission fields beyond the scope granted to the key. The end-to-end write-time impact was not fully confirmed by the reporter.
Security readout for executives and security teams
Plain-English summary
A flaw in the Grav API plugin can let a scoped API key access page-permission controls outside its intended limits. This could expose or possibly change sensitive authorization settings. The reported write-time impact remains unconfirmed, but the potential consequences and 9.3 CVSS score justify urgent attention.
Executive priority
Treat as an urgent patching and access-review item, especially where the API is network-accessible or scoped keys are widely distributed. Prioritize affected internet-facing or high-value Grav deployments. Avoid claiming compromise without supporting logs because exploitation and persistent unauthorized writes are not confirmed.
Technical view
Before version 1.0.18, BlueprintController.injectSecurityTab() uses raw isSuperAdmin() and hasPermission() checks without request context, preventing enforcement of scopeAllows(). Consequently, scoped API keys may reach security and permissions blueprint fields beyond their authorized scope. The reporter did not fully confirm that unauthorized changes persist end to end.
Likely exposure
Potentially exposed systems are Grav installations running the Grav API plugin before 1.0.18 and using scoped API keys. Practical risk depends on API reachability, possession of a scoped key, and whether the affected permission fields can be successfully written.
Exploitation context
The supplied sources do not establish active exploitation, and the CVE is not listed as KEV in the provided bundle. Abuse requires a scoped API key, but the affected authorization decision may treat that key as more privileged than intended. End-to-end unauthorized modification remains unconfirmed.
Researcher notes
The defect is an authorization-capability mismatch classified as CWE-863. The missing request parameter prevents scope-aware permission evaluation in injectSecurityTab(). Researchers should distinguish unauthorized blueprint visibility from durable permission modification; the supplied evidence supports the former more clearly than the latter.
Mitigation direction
Upgrade the Grav API plugin to version 1.0.18 or later.
Review vendor guidance before applying changes in production.
Rotate scoped API keys that may have been exposed or misused.
Restrict API accessibility until affected installations are updated.
Validation and detection
Inventory Grav API plugin versions and identify installations earlier than 1.0.18.
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Potential ATT&CK relevance
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
cwe · medium confidence lookup
CWE-863: Authorization and privilege behavior lookup
Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
The CVE wording references authentication or credential exposure, so valid-account and credential-access review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
2CVSS vectors
3Timeline events
1ADP providers
3Source links
SSVC decision data
CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: noneAutomatable: yesTechnical Impact: total
CVSS vector scores
2 official scores
We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
CWE-863 · source CWE mapping
Incorrect Authorization
Incorrect Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.