LiveActive security incident?Get immediate response
CVE Record

CVE-2026-77647: SPIP before 4.4.20 allows unauthenticated remote attackers to execute arbitrary code, as exploited in the w...

SPIP before 4.4.20 allows unauthenticated remote attackers to execute arbitrary code, as exploited in the wild in August 2026. This is related to incorrect identification of <?php blocks, and var_export's mishandling of certain cases such as presence of a '<' character.

CriticalCVSS 9.8Not KEV-listedUpdated
Glexia's TakeAutomated analysiscritical

Security readout for executives and security teams

Plain-English summary

A critical flaw in SPIP versions before 4.4.20 can let an unauthenticated internet attacker take control of the server remotely. Successful compromise could expose or alter data and disrupt the website. The supplied CVE record reports exploitation in the wild during August 2026.

Executive priority

Treat this as an emergency remediation and investigation item. Unauthenticated remote code execution, reported real-world exploitation, and possible full server impact justify immediate ownership, rapid inventory, prioritized upgrading, and compromise assessment for every exposed pre-4.4.20 installation.

Technical view

This is an unauthenticated remote code-execution vulnerability classified as CWE-94. SPIP incorrectly identifies PHP blocks, involving var_export handling of cases containing a '<' character. CVSS 3.1 scores it 9.8: network-accessible, low complexity, no privileges or user interaction, with high confidentiality, integrity, and availability impact.

Likely exposure

Internet-facing SPIP installations running any release before 4.4.20 are the clearest risk. Exposure cannot be quantified from the supplied sources. The structured affected-version entry is inconsistent with the narrative, so organizations should verify their exact installed release and vendor-supported upgrade path.

Exploitation context

The CVE description explicitly reports exploitation in the wild in August 2026, although the CVE is not marked as present in KEV. The supplied bundle provides no campaign details, indicators of compromise, targeted sectors, or evidence describing exploitation scale.

Researcher notes

The bundle supports the vulnerability class, root-cause outline, fixed SPIP release, CVSS vector, and reported exploitation. It does not supply technical indicators, exploit prerequisites beyond the CVSS vector, campaign attribution, or detailed branch coverage. The affected metadata lists version '0' with default status unaffected, conflicting with the narrative statement that versions before 4.4.20 are affected.

Mitigation direction

  • Upgrade affected SPIP installations to version 4.4.20 or later following vendor guidance.
  • Prioritize internet-facing systems and restrict external access until upgrading is complete.
  • Review the SPIP and Debian advisories for platform-specific package instructions.
  • Investigate potentially exposed servers for compromise rather than assuming upgrading removes prior intrusion.

Validation and detection

  • Inventory SPIP installations and record their exact installed versions.
  • Confirm every exposed instance runs SPIP 4.4.20 or later.
  • Verify the deployed package against applicable SPIP or Debian advisory information.
  • Review relevant application, web-server, and system logs for unexplained activity.
  • Check exposed hosts for unexpected files, processes, accounts, or configuration changes.
Prepared
Confidence
high
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-94: Code execution behavior lookup

Code execution and unsafe deserialization weaknesses often justify reviewing execution behavior and process telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Execution behavior lookup

The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-77647 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Critical
CVSS
9.8 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
3Timeline events
1ADP providers
3Source links

SSVC decision data

CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: noneAutomatable: yesTechnical Impact: total

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
9.8CVSS 3.1CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H3.95.9mitre

Vulnerability scoring details

Base CVSS 3.1 score

9.8Critical
CVSS 3.1 vector shape for CVE-2026-77647Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone

Vulnerability timeline

Timeline events are normalized from CVE metadata, CNA source timelines, ADP timelines, and KEV metadata when present.

  1. CVE reservedCVE Program

    The CVE ID was reserved by the assigning CNA.

  2. CVE publishedCVE Program

    The CVE record was published.

  3. CVE updatedCVE Program

    The CVE record metadata indicates this as the latest update time.

ADP provider summaries

CISA-ADPCISA ADP Vulnrichment
other:ssvc
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
SPIPSPIP0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-94 · source CWE mapping

Improper Control of Generation of Code

Improper Control of Generation of Code represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.