LiveActive security incident?Get immediate response
CVE Record

CVE-2026-75835: Grav API Plugin before 1.0.14 Missing Authorization

Grav API plugin (getgrav/grav-plugin-api) before 1.0.14 contains a missing authorization vulnerability in userPassesAuthorize() (AbstractApiController.php). The function fails to consult the calling request's API key scopes, relying instead on the account's raw super-admin flag and ACL grants. As a result, an authenticated attacker holding a scoped API key minted on a privileged account can bypass their declared scope restrictions to access authorize-gated UI metadata and item definitions (sidebar/menubar/widget items and users-list columns/row-actions/filter-tabs) that their key scope should deny, resulting in information disclosure.

CriticalCVSS 9.3Not KEV-listedUpdated
Glexia's TakeAutomated analysiscritical

Security readout for executives and security teams

Plain-English summary

A flaw in the Grav API plugin can let someone with a restricted API key inherit the broader permissions of the privileged account that issued it. This may expose administrative interface metadata and user-list definitions that the key’s scope should block. The supplied record rates it critical, although the described demonstrated consequence is information disclosure.

Executive priority

Prioritize rapid inventory and upgrade, especially on internet-accessible systems using privileged-account API keys. Treat exposure as urgent because authorization boundaries can fail silently. However, communicate that the supplied evidence describes information disclosure and does not establish active exploitation or confirmed integrity and availability impact.

Technical view

Before version 1.0.14, userPassesAuthorize() in AbstractApiController.php does not evaluate the request API key’s scopes. It instead uses the issuing account’s super-admin status and ACL grants, allowing scoped keys from privileged accounts to bypass authorization checks for sidebar, menubar, widget, and users-list definitions.

Likely exposure

Exposure is most likely where the Grav API plugin is older than 1.0.14 and scoped API keys were issued from privileged or super-admin accounts. Exploitation requires a valid scoped key according to the description. The supplied PR:N CVSS vector conflicts with that authenticated-attacker requirement.

Exploitation context

The bundle reports no CISA KEV listing and provides no evidence of active exploitation. Abuse is remotely reachable and described as low complexity once an attacker possesses an affected API key. Do not treat the critical CVSS score alone as proof of exploitation in the wild.

Researcher notes

The authorization decision uses account-level super-admin and ACL grants without consulting request-specific scopes. The stated affected boundary is before 1.0.14. The CVSS 4.0 vector claims no privileges and high confidentiality, integrity, and availability impact, but the narrative requires an authenticated key and documents information disclosure; this discrepancy needs vendor clarification.

Mitigation direction

  • Upgrade the Grav API plugin to version 1.0.14 or later after reviewing vendor guidance.
  • Until upgraded, revoke or restrict scoped API keys issued from privileged accounts.
  • Rotate potentially exposed keys and minimize issuing privileged-account API credentials.
  • Review access to affected administrative metadata and user-list definition endpoints.

Validation and detection

  • Inventory Grav API plugin versions and identify every installation older than 1.0.14.
  • Identify scoped API keys issued from super-admin or broadly privileged accounts.
  • Verify restricted keys cannot access authorize-gated metadata outside their declared scopes.
  • Review available API access records for unexpected requests using affected scoped keys.
Prepared
Confidence
medium
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-862: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-75835 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Critical
CVSS
9.3 (4.0)
Known Exploited
No
Published

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

2CVSS vectors
3Timeline events
1ADP providers
3Source links

SSVC decision data

CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: pocAutomatable: noTechnical Impact: partial

CVSS vector scores

2 official scores

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
9.3CVSS 4.0CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N——VulnCheck
4.3CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N2.81.4VulnCheck

Vulnerability scoring details

Base CVSS 4.0 score

9.3Critical
CVSS 4.0 vector shape for CVE-2026-75835Attack VectorAttack ComplexityAttack RequirementsPrivileges RequiredUser InteractionVS ConfidentialityVS IntegrityVS AvailabilitySS ConfidentialitySS IntegritySS Availability

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Attack Requirements
NonePresent
Privileges Required
NoneLowHigh
User Interaction
NonePassiveActive
VS Confidentiality
HighLowNone
VS Integrity
HighLowNone
VS Availability
HighLowNone
SS Confidentiality
HighLowNone
SS Integrity
HighLowNone
SS Availability
HighLowNone

Vulnerability timeline

Timeline events are normalized from CVE metadata, CNA source timelines, ADP timelines, and KEV metadata when present.

  1. CVE reservedCVE Program

    The CVE ID was reserved by the assigning CNA.

  2. CVE publishedCVE Program

    The CVE record was published.

  3. CVE updatedCVE Program

    The CVE record metadata indicates this as the latest update time.

ADP provider summaries

CISA-ADPCISA ADP Vulnrichment
other:ssvc

Source materials

Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
getgravgrav0, 1.0.14unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-862 · source CWE mapping

Missing Authorization

Missing Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.