Security readout for executives and security teams
Plain-English summary
A website running WP Compress before version 7.20.01 could allow an unauthenticated internet attacker to execute code on the server. Successful compromise could expose data, alter site content, install persistence, or disrupt service. The supplied record rates the issue CVSS 10.0, but provides limited technical detail.
Executive priority
Treat as an immediate remediation priority for public-facing WordPress systems. Establish exposure today, update or isolate affected installations, and investigate exposed hosts. Escalate any unexplained changes as a potential incident. Evidence of exploitation is not supplied, but the stated impact and unauthenticated attack path justify emergency handling.
Technical view
CVE-2026-73343 is classified as CWE-94 and described as unauthenticated remote code execution in the WordPress WP Compress plugin before 7.20.01. The CVSS 3.1 vector indicates network access, low complexity, no privileges, no user interaction, changed scope, and high confidentiality, integrity, and availability impact.
Likely exposure
Internet-accessible WordPress sites running WP Compress earlier than 7.20.01 are the stated exposure. The bundle does not identify vulnerable functions or configuration prerequisites. Its structured affected-version field says “n/a” and defaults to unaffected, conflicting with the narrative version range; confirm installed versions directly.
Exploitation context
The supplied bundle marks this CVE as absent from KEV and provides no evidence of active exploitation or a public proof of concept. That absence does not establish safety. Unauthenticated, network-reachable code execution warrants urgent action because exploitation could require no account or user interaction.
Researcher notes
Public technical evidence in the bundle is sparse: no vulnerable endpoint, root cause detail, prerequisite, advisory text, or exploitation telemetry is included. The narrative identifies versions before 7.20.01, while structured affected data lists versions as “n/a” with default unaffected. Avoid broader product or version conclusions until authoritative records clarify this inconsistency.
Mitigation direction
Inventory WordPress sites for the WP Compress plugin and record installed versions.
Update affected installations to version 7.20.01 or later, following verified vendor or Patchstack guidance.
If updating is impossible, disable or remove the plugin until authoritative remediation guidance is available.
Review potentially exposed sites for compromise and rotate secrets if intrusion is suspected.
Validation and detection
Confirm each site’s WP Compress version is 7.20.01 or later.
Verify the plugin is disabled or absent wherever updating was not possible.
Review web, application, and hosting logs for unexplained requests, file changes, or code execution.
Check WordPress files, administrators, scheduled tasks, and integrations for unauthorized changes.
Confirm the final affected-version scope against updated CVE, vendor, or Patchstack information.
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Potential ATT&CK relevance
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
cwe · medium confidence lookup
CWE-94: Code execution behavior lookup
Code execution and unsafe deserialization weaknesses often justify reviewing execution behavior and process telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
1CVSS vectors
3Timeline events
1ADP providers
2Source links
SSVC decision data
CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: noneAutomatable: yesTechnical Impact: total
CVSS vector scores
1 official score
We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
CWE-94 · source CWE mapping
Improper Control of Generation of Code
Improper Control of Generation of Code represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.