LiveActive security incident?Get immediate response
CVE Record

CVE-2026-73257: Mongoose: Content-Length + Transfer-Encoding coexistence enables request smuggling

Mongoose is an embedded web server and network library. Priro to version 7.22, a remote unauthenticated attacker can send an HTTP request containing both Content-Length and Transfer-Encoding: chunked. The cl_count and te_count checks in the mg_http_parse() and http_cb() paths in src/http.c accept both headers and prioritize chunked encoding, while a Content-Length-preferring reverse proxy can use a different request boundary. This CL.TE desynchronization can inject requests that access or modify resources in another user context. This issue is fixed in version 7.22.

CriticalCVSS 9.1Not KEV-listedUpdated
Glexia's TakeAutomated analysiscritical

Security readout for executives and security teams

Plain-English summary

Mongoose versions before 7.22 can interpret ambiguous HTTP requests differently from a reverse proxy. An unauthenticated remote attacker may exploit that disagreement to make an injected request appear in another user’s context, potentially exposing or changing sensitive resources. The issue is critical because no credentials or user interaction are required.

Executive priority

Treat this as an urgent remediation item for externally reachable or reverse-proxied deployments. Direct teams to inventory embedded Mongoose copies and upgrade affected systems to 7.22 or later. There is no supplied evidence of active exploitation, but the potential for cross-user data access or modification justifies accelerated action.

Technical view

CVE-2026-73257 is a CWE-444 CL.TE request-smuggling flaw in Mongoose. The mg_http_parse() and http_cb() paths accept Content-Length together with Transfer-Encoding: chunked and prioritize chunked framing. A Content-Length-preferring reverse proxy may identify a different request boundary, enabling connection desynchronization. Version 7.22 fixes the issue.

Likely exposure

Exposure is most likely where Mongoose earlier than 7.22 processes HTTP traffic behind a reverse proxy that resolves conflicting framing headers differently. Internet-facing services and embedded products bundling vulnerable Mongoose versions warrant urgent inventory. The supplied sources do not identify specific downstream products or configurations.

Exploitation context

The described attack is remote, unauthenticated, low complexity, and requires no user interaction. Successful exploitation could provide high confidentiality and integrity impact without stated availability impact. The source bundle marks this CVE as absent from KEV and provides no evidence of active exploitation.

Researcher notes

The key exposure condition is parser disagreement: Mongoose selects chunked framing while an intermediary may select Content-Length. Review complete HTTP connection paths, including proxies and reused backend connections. The supplied evidence establishes affected versions and the fixed release, but does not establish exploit prevalence, affected downstream vendors, or universal exploitability across configurations.

Mitigation direction

  • Upgrade Mongoose to version 7.22 or later.
  • Identify applications and embedded products that bundle Mongoose earlier than 7.22.
  • Prioritize upgrades for instances behind reverse proxies or exposed to untrusted HTTP traffic.
  • Consult the Mongoose advisory and release guidance for deployment-specific precautions.

Validation and detection

  • Confirm each deployed or embedded Mongoose version from build manifests and product inventories.
  • Map whether vulnerable instances receive traffic through a reverse proxy.
  • Verify upgraded builds resolve Mongoose to version 7.22 or later.
  • Confirm affected services were restarted or redeployed with the updated library.
  • Use approved defensive testing to verify ambiguous framing requests are rejected consistently.
Prepared
Confidence
high
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · low confidence lookup

CWE-444: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-73257 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Critical
CVSS
9.1 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
3Timeline events
1ADP providers
5Source links

SSVC decision data

CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: pocAutomatable: yesTechnical Impact: total

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
9.1CVSS 3.1CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N3.95.2GitHub_M

Vulnerability scoring details

Base CVSS 3.1 score

9.1Critical
CVSS 3.1 vector shape for CVE-2026-73257Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone

Vulnerability timeline

Timeline events are normalized from CVE metadata, CNA source timelines, ADP timelines, and KEV metadata when present.

  1. CVE reservedCVE Program

    The CVE ID was reserved by the assigning CNA.

  2. CVE publishedCVE Program

    The CVE record was published.

  3. CVE updatedCVE Program

    The CVE record metadata indicates this as the latest update time.

ADP provider summaries

CISA-ADPCISA ADP Vulnrichment
other:ssvc

Source materials

Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
cesantamongoose< 7.22Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-444 · source CWE mapping

Inconsistent Interpretation of HTTP Requests

Inconsistent Interpretation of HTTP Requests represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.