LiveActive security incident?Get immediate response
CVE Record

CVE-2026-72829: Grav before 1.0.13 API Key Scope Bypass via UsersController

The Grav API plugin (getgrav/grav-plugin-api) before 1.0.13 contains an API-key scope-cap bypass in UsersController's create() and update() methods. These methods enforce the scope cap only for api.users.write, but gate super-privilege grants on a bare isSuperAdmin() check that reads access.api.super directly without consulting the key's scopes. As a result, an api.users.write-scoped key minted on a super account can set access.api.super or assign a super-granting group to mint or promote a full super account, then authenticate as that account for uncapped administrative privileges.

HighCVSS 8.8Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

A limited API key tied to a Grav super administrator can bypass its intended scope and create or promote another full super administrator. This could give an attacker complete administrative control, including access to sensitive data, configuration changes, and service disruption.

Executive priority

Treat affected, API-accessible deployments as urgent because a qualifying limited key can become full administrative control. Prioritize version verification, upgrading, credential rotation, and privileged-account review. Lower priority only when the API plugin is absent, already fixed, or no qualifying keys exist.

Technical view

Grav API plugin versions before 1.0.13 incompletely enforce API-key scope limits in UsersController create() and update(). Although api.users.write is checked, the super-administrator decision reads access.api.super without applying the key’s scopes, permitting unauthorized super privileges through direct access settings or super-granting groups.

Likely exposure

Exposure is limited to Grav deployments running the API plugin before 1.0.13 where a key with api.users.write was issued from a super account. Internet-accessible API endpoints increase practical risk. The supplied sources do not establish whether the plugin or qualifying keys are commonly deployed.

Exploitation context

Exploitation requires an existing api.users.write-scoped key associated with a super account; it is not described as unauthenticated. Successful abuse can produce an unrestricted administrator account. The CVE is not listed as KEV in the supplied bundle, and no cited source establishes active exploitation.

Researcher notes

The authorization flaw is CWE-269 and has CVSS 3.1 score 8.8: network reachable, low complexity, low privileges, no user interaction, and high confidentiality, integrity, and availability impact. Evidence does not establish public exploit availability, observed attacks, deployment prevalence, or persistence mechanisms.

Mitigation direction

  • Upgrade the Grav API plugin to version 1.0.13 or later, following vendor guidance.
  • Revoke or rotate API keys issued from super-administrator accounts.
  • Review and remove unauthorized super accounts, privileged groups, and access.api.super assignments.
  • Restrict API access at the network layer until affected deployments are updated.

Validation and detection

  • Inventory Grav deployments and confirm the installed API plugin version.
  • Identify api.users.write keys originating from super-administrator accounts.
  • Audit recent user creation, user updates, privileged group assignments, and super-access changes.
  • Confirm restricted keys cannot grant access.api.super or super-granting groups after remediation.
Prepared
Confidence
high
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-269: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-72829 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
8.8 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

2CVSS vectors
3Timeline events
1ADP providers
3Source links

SSVC decision data

CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: pocAutomatable: yesTechnical Impact: total

CVSS vector scores

2 official scores

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
8.8CVSS 3.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H2.85.9VulnCheck
8.7CVSS 4.0HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N——VulnCheck

Vulnerability scoring details

Base CVSS 4.0 score

8.7High
CVSS 4.0 vector shape for CVE-2026-72829Attack VectorAttack ComplexityAttack RequirementsPrivileges RequiredUser InteractionVS ConfidentialityVS IntegrityVS AvailabilitySS ConfidentialitySS IntegritySS Availability

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Attack Requirements
NonePresent
Privileges Required
NoneLowHigh
User Interaction
NonePassiveActive
VS Confidentiality
HighLowNone
VS Integrity
HighLowNone
VS Availability
HighLowNone
SS Confidentiality
HighLowNone
SS Integrity
HighLowNone
SS Availability
HighLowNone

Vulnerability timeline

Timeline events are normalized from CVE metadata, CNA source timelines, ADP timelines, and KEV metadata when present.

  1. CVE reservedCVE Program

    The CVE ID was reserved by the assigning CNA.

  2. CVE publishedCVE Program

    The CVE record was published.

  3. CVE updatedCVE Program

    The CVE record metadata indicates this as the latest update time.

ADP provider summaries

CISA-ADPCISA ADP Vulnrichment
other:ssvc

Source materials

Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
getgravgrav0, 1.0.13unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-269 · source CWE mapping

Improper Privilege Management

Improper Privilege Management represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.