LiveActive security incident?Get immediate response
CVE Record

CVE-2026-5130: Debugger & Troubleshooter <= 1.3.2 - Unauthenticated Privilege Escalation to Administrator via Cookie Manipulation

The Debugger & Troubleshooter plugin for WordPress was vulnerable to Unauthenticated Privilege Escalation in versions up to and including 1.3.2. This was due to the plugin accepting the wp_debug_troubleshoot_simulate_user cookie value directly as a user ID without any cryptographic validation or authorization checks. The cookie value was used to override the determine_current_user filter, which allowed unauthenticated attackers to impersonate any user by simply setting the cookie to their target user ID. This made it possible for unauthenticated attackers to gain administrator-level access and perform any privileged actions including creating new administrator accounts, modifying site content, installing plugins, or taking complete control of the WordPress site. The vulnerability was fixed in version 1.4.0 by implementing a cryptographic token-based validation system where only administrators can initiate user simulation, and the cookie contains a random 64-character token that must be validated against database-stored mappings rather than accepting arbitrary user IDs.

HighCVSS 8.8Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

A vulnerable WordPress debugging plugin could let an unauthenticated attacker impersonate an administrator by manipulating a cookie. If exploited, the attacker could take over the site, create admin users, change content, or install plugins. The reported fix is version 1.4.0.

Executive priority

Treat as urgent for any internet-facing WordPress site using this plugin. The business risk is full site takeover, content tampering, and persistence through new administrator accounts. Patch or remove the plugin promptly.

Technical view

Debugger & Troubleshooter through 1.3.2 trusted the wp_debug_troubleshoot_simulate_user cookie as a user ID and used it in determine_current_user without cryptographic validation or authorization checks. Version 1.4.0 changed this to token-based validation with database-stored mappings initiated by administrators.

Likely exposure

Public WordPress sites running Debugger & Troubleshooter versions up to and including 1.3.2 are the primary exposure. Sites already updated to 1.4.0 are described as fixed by the source bundle.

Exploitation context

The source describes unauthenticated privilege escalation to administrator. CISA KEV is false in the provided data, and no cited source confirms active exploitation. The issue is high urgency because exploitation would provide full WordPress administrative control.

Researcher notes

The public description and Trac references support a cookie trust flaw mapped to CWE-565. The provided CVSS vector lists PR:L, while the narrative says unauthenticated; note this discrepancy during triage. No public exploitation evidence was provided.

Mitigation direction

  • Update Debugger & Troubleshooter to version 1.4.0 or later.
  • Disable and remove the plugin if an immediate update is not possible.
  • Review vendor and WordPress plugin guidance for any additional instructions.
  • After updating, review administrator accounts and recent privileged changes.

Validation and detection

  • Inventory WordPress sites for the Debugger & Troubleshooter plugin.
  • Confirm installed plugin versions are not 1.3.2 or older.
  • Verify version 1.4.0 or later is deployed where the plugin remains active.
  • Review recent admin user creation, plugin installs, and content changes.
  • Check available logs for suspicious unauthenticated access around the disclosure window.
Prepared
Confidence
high
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · low confidence lookup

CWE-565: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Credential and access behavior lookup

The CVE wording references authentication or credential exposure, so valid-account and credential-access review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
description · low confidence lookup

Privilege behavior lookup

The CVE wording references privilege impact, so privilege escalation and authorization behavior review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
description · low confidence lookup

Database behavior lookup

The CVE wording references database injection or access, so collection and exfiltration review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-5130 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
8.8 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
4Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
8.8CVSS 3.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H2.85.9Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

8.8High
CVSS 3.1 vector shape for CVE-2026-5130Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
jhimrossDebugger & Troubleshooter0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-565 · source CWE mapping

Reliance on Cookies without Validation and Integrity Checking

Reliance on Cookies without Validation and Integrity Checking represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.