Security readout for executives and security teams
Plain-English summary
CVE-2026-4622 is a command injection issue in multiple NEC Platforms Aterm Series devices. If successfully exploited, an attacker could run operating-system commands on the device over the network. The published CVSS 4.0 score is 7.1 High, but the vector indicates high privileges, high complexity, and user interaction are required.
Executive priority
Prioritize remediation where affected Aterm devices support business networks or are reachable by untrusted users. The issue has high potential device impact, but published scoring suggests exploitation is not trivial. Treat as a scheduled high-priority firmware update unless local exposure is broad.
Technical view
The vulnerability is CWE-78 OS command injection affecting listed NEC Aterm models before specific firmware versions. The CVSS vector is AV:N/AC:H/AT:N/PR:H/UI:A with high confidentiality, integrity, and availability impact on the vulnerable system. No CPEs, exploit procedure, or proof-of-concept details are included in the provided sources.
Likely exposure
Exposure is limited to organizations or users operating the named NEC Aterm models on vulnerable firmware. Because the attack vector is network-based, devices reachable by an attacker on relevant networks are the primary concern. The sources do not clarify whether Internet exposure is required or common.
Exploitation context
The sources state arbitrary OS commands can be executed via network, but do not report active exploitation. CISA KEV status is false in the provided bundle. CVSS indicates exploitation requires high privileges and user interaction, reducing likelihood but not impact.
Researcher notes
Evidence is limited to the CVE record, CVE List entry, and NEC advisory URL in the bundle. No exploit, IoCs, detailed vulnerable endpoint, or workaround is provided. Default affected status is unknown and no CPEs are listed, so asset matching may require model and firmware confirmation.
Mitigation direction
- Update affected devices to the fixed firmware version or later listed by NEC.
- WG2600HS: update to Ver. 1.7.2 or later.
- WF1200CR: update to Ver. 1.6.0 or later.
- WG1200CR: update to Ver. 1.5.0 or later.
- WG2600HP4 and WG2600HM4: update to Ver. 1.4.2 or later.
- WG2600HS2 and WX3000HP2: update to Ver. 1.3.2 or later.
Validation and detection
- Inventory NEC Aterm devices and record exact model and firmware version.
- Compare firmware versions against the affected-version list in NEC’s advisory.
- Confirm updates completed successfully through the device’s firmware information screen or vendor-supported method.
- Review network reachability to affected devices and restrict unnecessary access.
- Monitor NEC’s advisory for any revised guidance or additional affected products.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-78: Command execution behavior lookup
Command injection weaknesses can lead defenders to review execution techniques and command interpreter telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupExecution behavior lookup
The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
Open ATT&CK lookupCVE-2026-4622 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- High
- CVSS
- 7.1 (4.0)
- Known Exploited
- No
- Published
Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N——Primary CVE scoreVulnerability scoring details
Base CVSS 4.0 score
7.1HighVector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Source materials
- CVE List V5 sourceCVE List V5
- https://jpn.nec.com/security-info/secinfo/nv26-001_en.htmlCVE reference
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
