LiveActive security incident?Get immediate response
CVE Record

CVE-2026-4257: Contact Form by Supsystic <= 1.7.36 - Unauthenticated Server-Side Template Injection via Prefill Functionality

The Contact Form by Supsystic plugin for WordPress is vulnerable to Server-Side Template Injection (SSTI) leading to Remote Code Execution (RCE) in all versions up to, and including, 1.7.36. This is due to the plugin using the Twig `Twig_Loader_String` template engine without sandboxing, combined with the `cfsPreFill` prefill functionality that allows unauthenticated users to inject arbitrary Twig expressions into form field values via GET parameters. This makes it possible for unauthenticated attackers to execute arbitrary PHP functions and OS commands on the server by leveraging Twig's `registerUndefinedFilterCallback()` method to register arbitrary PHP callbacks.

CriticalCVSS 9.8Not KEV-listedUpdated
Glexia's TakeAutomated analysiscritical

Security readout for executives and security teams

Plain-English summary

A WordPress contact-form plugin flaw can let an unauthenticated internet user run code on the web server. Public sources rate it critical because attack requires no login or user interaction. Organizations using Contact Form by Supsystic at version 1.7.36 or older should treat exposed sites as high priority.

Executive priority

Immediate action is warranted for any public WordPress site using this plugin. The business risk is potential server takeover, data theft, site defacement, or service disruption without requiring attacker credentials. Absence of confirmed active exploitation lowers certainty, not urgency.

Technical view

Contact Form by Supsystic <= 1.7.36 is vulnerable to unauthenticated server-side template injection in prefill handling. The plugin used Twig_Loader_String without sandboxing, allowing user-controlled GET parameter content to be interpreted as Twig expressions. The CVE description says this can lead to arbitrary PHP function and OS command execution. CWE-94, CVSS 9.8.

Likely exposure

Internet-facing WordPress sites running Contact Form by Supsystic versions up to and including 1.7.36 are the primary concern. Exposure is higher where public forms are reachable without authentication. The provided affected-product metadata is inconsistent, but the CVE title and description clearly identify <= 1.7.36 as vulnerable.

Exploitation context

No provided source or KEV listing indicates active exploitation. However, the vulnerability is network-reachable, unauthenticated, low-complexity, and can result in full confidentiality, integrity, and availability impact. Public code references and a WordPress repository changeset may help defenders validate, but they also increase urgency to patch quickly.

Researcher notes

The key issue is unsandboxed Twig string template evaluation reachable through cfsPreFill prefill functionality. Public references include the vulnerable code location and a WordPress changeset. Avoid assuming exploitation in the wild from severity alone. Validate exact deployed versions and compare against the repository fix history.

Mitigation direction

  • Inventory WordPress sites for Contact Form by Supsystic installations.
  • Update the plugin to a version newer than 1.7.36, if available.
  • If no safe update is available, disable or remove the plugin.
  • Check Supsystic, WordPress plugin repository, and Wordfence guidance for current remediation details.
  • Prioritize externally exposed WordPress sites and high-value business web properties.

Validation and detection

  • Confirm plugin version on each WordPress site.
  • Verify vulnerable versions are upgraded beyond 1.7.36 or removed.
  • Review web logs for unusual prefill-related query parameters.
  • Investigate potentially affected servers for unauthorized file changes or processes.
  • Confirm compensating controls do not replace applying the vendor fix.
Prepared
Confidence
high
Sources
5

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-94: Code execution behavior lookup

Code execution and unsafe deserialization weaknesses often justify reviewing execution behavior and process telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Execution behavior lookup

The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-4257 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Critical
CVSS
9.8 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
4Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
9.8CVSS 3.1CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H3.95.9Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

9.8Critical
CVSS 3.1 vector shape for CVE-2026-4257Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
supsysticcomContact Form by Supsystic0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-94 · source CWE mapping

Improper Control of Generation of Code ('Code Injection')

Improper Control of Generation of Code ('Code Injection') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.