LiveActive security incident?Get immediate response
CVE Record

CVE-2026-3534: Astra <= 4.12.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Post Meta

The Astra theme for WordPress is vulnerable to Stored Cross-Site Scripting via the `ast-page-background-meta` and `ast-content-background-meta` post meta fields in all versions up to, and including, 4.12.3. This is due to insufficient input sanitization on meta registration and missing output escaping in the `astra_get_responsive_background_obj()` function for four CSS-context sub-properties (`background-color`, `background-image`, `overlay-color`, `overlay-gradient`). This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

MediumCVSS 6.4Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-3534 affects the Astra WordPress theme through version 4.12.3. A logged-in user with Contributor-level access or higher can save script content in page background metadata. That script can run for people who view the affected page, creating risk of account compromise, content manipulation, or visitor trust damage.

Executive priority

Treat as a timely WordPress maintenance issue, not an emergency based on current evidence. Prioritize sites with many contributors, external authors, or high-traffic public pages. Updating the theme and reviewing privileged content accounts should be scheduled promptly.

Technical view

Stored XSS exists in Astra post meta fields ast-page-background-meta and ast-content-background-meta. Sources cite insufficient sanitization during meta registration and missing escaping in astra_get_responsive_background_obj() for CSS-context background sub-properties. CVSS 3.1 is 6.4, requiring network access and low privileges, with changed scope and low confidentiality/integrity impact.

Likely exposure

WordPress sites using the Astra theme versions up to and including 4.12.3 are potentially exposed, especially where Contributor or higher accounts exist. Sites without untrusted or numerous content contributors have lower practical exposure, but compromised author accounts could still abuse it.

Exploitation context

The source bundle does not show CISA KEV listing or cited evidence of active exploitation. Exploitation requires authenticated Contributor-level access or higher. The payload is stored and executes when a user accesses an injected page, according to the CVE description.

Researcher notes

Relevant source references point to Astra 4.12.3 common-functions.php around astra_get_responsive_background_obj() and metabox registration around the affected fields. The 4.12.4 changeset is the key remediation reference. Evidence is sufficient for exposure triage, but no public active-exploitation signal is provided.

Mitigation direction

  • Update the Astra theme to version 4.12.4 or later where available.
  • Review vendor and Wordfence guidance for any additional remediation details.
  • Limit Contributor and higher roles to trusted users only.
  • Remove or downgrade unused WordPress accounts with content-editing permissions.
  • Review affected pages and metadata for unexpected background-related content.

Validation and detection

  • Inventory WordPress sites using the Astra theme.
  • Confirm whether Astra is version 4.12.3 or earlier.
  • Verify Astra is updated to 4.12.4 or later.
  • Review Contributor, Author, Editor, and Administrator account lists.
  • Inspect relevant page background metadata for unexpected values.
  • Check web logs and CMS audit logs for suspicious content edits.
Prepared
Confidence
high
Sources
8

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-79: User-session and phishing behavior lookup

Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-3534 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
6.4 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
5Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
6.4CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N3.12.7Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

6.4Medium
CVSS 3.1 vector shape for CVE-2026-3534Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
brainstormforceAstra0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-79 · source CWE mapping

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.