Security readout for executives and security teams
Plain-English summary
CVE-2026-3427 affects the Yoast SEO WordPress plugin through version 27.1.1. A logged-in user with Contributor or higher permissions can store malicious script in a Yoast-related block attribute. The script runs when someone views the affected page, creating risk to site users and administrators.
Executive priority
Treat as a timely plugin update and account-governance issue, not an emergency based on current evidence. Prioritize sites with many contributors, external authors, or high-value admin sessions. Complete remediation in the next normal WordPress maintenance window unless local indicators suggest abuse.
Technical view
The issue is stored cross-site scripting in the `jsonText` block attribute. Sources cite insufficient input sanitization and output escaping in Yoast SEO up to and including 27.1.1. CVSS 3.1 is 6.4, with low privileges required, network access, changed scope, and low confidentiality and integrity impact.
Likely exposure
WordPress sites running Yoast SEO versions up to and including 27.1.1 are potentially exposed, especially where Contributor-level accounts are allowed or compromised. Public self-registration, many authors, agencies, or weak account governance increase practical risk.
Exploitation context
No source in the bundle states active exploitation, and CISA KEV status is false. Exploitation requires authenticated Contributor-level or higher access. Impact depends on who views the injected page; stored XSS can affect visitors or privileged WordPress users.
Researcher notes
The vulnerability is tied to WordPress block data handling for `jsonText`, with references to Yoast code, a GitHub pull request, and WordPress.org changeset 3475308. The bundle does not provide public exploitation evidence or a detailed vendor advisory naming a fixed release.
Mitigation direction
- Inventory WordPress sites using the Yoast SEO plugin.
- Update Yoast SEO beyond 27.1.1 when a fixed release is available.
- Review Yoast and WordPress plugin guidance for the confirmed fixed version.
- Restrict Contributor and higher roles to trusted users only.
- Remove unused author accounts and enforce strong authentication.
- Review recent content changes by Contributor-level users.
Validation and detection
- Check installed Yoast SEO versions across all WordPress sites.
- Flag any Yoast SEO installation at 27.1.1 or earlier.
- Confirm the installed build includes Yoast PR 23035 or changeset 3475308.
- Review pages edited by Contributor-level users for unexpected scripts.
- Verify Contributor users cannot publish unreviewed risky content.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-79: User-session and phishing behavior lookup
Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupCVE-2026-3427 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- Medium
- CVSS
- 6.4 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N3.12.7Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
6.4MediumVector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Source materials
- CVE List V5 sourceCVE List V5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fee1fef5-5716-49e0-a04e-d0dae527fcfc?source=cveCVE reference
- https://plugins.trac.wordpress.org/browser/wordpress-seo/tags/27.0/src/generators/schema/howto.php#L125CVE reference
- https://plugins.trac.wordpress.org/browser/wordpress-seo/tags/27.0/inc/class-wpseo-utils.php#L915CVE reference
- https://github.com/Yoast/wordpress-seo/pull/23035CVE reference
- https://plugins.trac.wordpress.org/changeset/3475308/wordpress-seoCVE reference
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
