LiveActive security incident?Get immediate response
CVE Record

CVE-2026-3226: LearnPress <= 4.3.2.8 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Email Notification Triggering

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to unauthorized email notification triggering due to missing capability checks on all 10 functions in the SendEmailAjax class in all versions up to, and including, 4.3.2.8. The AbstractAjax::catch_lp_ajax() dispatcher verifies a wp_rest nonce but performs no current_user_can() check before dispatching to handler functions. The wp_rest nonce is embedded in the frontend JavaScript for all authenticated users. This makes it possible for authenticated attackers, with Subscriber-level access and above, to trigger arbitrary email notifications to admins, instructors, and users, enabling email flooding, social engineering, and impersonation of admin decisions regarding instructor requests.

MediumCVSS 4.3Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-3226 affects the LearnPress WordPress LMS plugin through version 4.3.2.8. A logged-in low-privilege user can trigger email notifications they should not control. Business impact is mainly trust and operational disruption: email flooding, misleading messages, and possible social engineering around instructor or admin decisions.

Executive priority

Address in the normal vulnerability remediation cycle, faster for public LMS sites with open registration. The issue is not a takeover bug, but it can damage trust in platform emails and create avoidable support or phishing-like incidents.

Technical view

The issue is missing authorization checks in all 10 SendEmailAjax functions. AbstractAjax::catch_lp_ajax() validates a wp_rest nonce but does not perform current_user_can() before dispatch. Because the nonce is available to authenticated users, Subscriber-level users can trigger notification flows. CVSS is 4.3, CWE-862.

Likely exposure

Exposure is limited to WordPress sites running LearnPress through 4.3.2.8, especially sites allowing public registration or many Subscriber-level accounts. Sites without authenticated untrusted users have lower practical risk.

Exploitation context

The CVE requires authenticated access but no user interaction. The provided sources do not show CISA KEV listing or active exploitation. Abuse would likely focus on email flooding, impersonation-like messaging, or social engineering rather than system takeover.

Researcher notes

Primary evidence points to nonce-only AJAX dispatch and missing capability checks. The WordPress changeset comparing 4.3.2.7 to 4.3.3 is relevant for remediation review. Evidence provided does not establish active exploitation or impact beyond unauthorized notification triggering.

Mitigation direction

  • Upgrade LearnPress to a version newer than 4.3.2.8, such as 4.3.3 or later if available.
  • If immediate upgrade is unavailable, restrict untrusted user registration and low-privilege account access.
  • Monitor outbound WordPress/LearnPress email volume for unusual notification spikes.
  • Review vendor guidance and changelog for the confirmed fixed release.

Validation and detection

  • Inventory WordPress sites using the LearnPress plugin.
  • Check the installed LearnPress version against vulnerable versions through 4.3.2.8.
  • Review whether public registration or Subscriber-level access is enabled.
  • Inspect logs for unusual LearnPress notification activity from authenticated low-privilege users.
  • Confirm upgraded code includes added authorization checks in SendEmailAjax handlers.
Prepared
Confidence
high
Sources
7

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-862: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-3226 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
4.3 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
6Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
4.3CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N2.81.4Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

4.3Medium
CVSS 3.1 vector shape for CVE-2026-3226Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
thimpressLearnPress – WordPress LMS Plugin for Create and Sell Online Courses0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-862 · source CWE mapping

Missing Authorization

Missing Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.