Security readout for executives and security teams
Plain-English summary
CVE-2026-3191 affects the WordPress Minify HTML plugin through version 2.1.12. A malicious site or link could trick a logged-in administrator into changing plugin settings. This is not shown as actively exploited, but it can affect site integrity and availability depending on how settings are changed.
Executive priority
Treat as a normal-priority WordPress plugin remediation. It needs administrator interaction, but public disclosure and broad WordPress deployment patterns make timely inventory and update important.
Technical view
The issue is CWE-352 cross-site request forgery in the minify_html_menu_options function, caused by missing or incorrect nonce validation. The CVSS 3.1 score is 5.4 with required user interaction and no privileges needed by the attacker. Impact is limited integrity and availability; confidentiality impact is not indicated.
Likely exposure
Exposure is limited to WordPress sites running the Minify HTML plugin at versions up to and including 2.1.12, especially where administrators browse email or external sites while authenticated to WordPress.
Exploitation context
Sources describe a forged request that requires tricking a site administrator into taking an action such as clicking a link. The CVE is not listed in KEV, and the provided sources do not state active exploitation.
Researcher notes
The public record identifies the vulnerable function and nonce-validation weakness. The WordPress Trac links provide code context and a changeset, but the bundle does not include detailed release notes or evidence of exploitation in the wild.
Mitigation direction
- Inventory WordPress sites for the Minify HTML plugin.
- Upgrade Minify HTML beyond version 2.1.12 if a fixed release is available.
- Review the referenced WordPress plugin changeset for the vendor-side fix.
- If no update is available, consider disabling the plugin until vendor guidance is clear.
- Remind administrators not to click untrusted links while logged into WordPress.
Validation and detection
- Confirm whether Minify HTML is installed on each WordPress site.
- Check the installed plugin version for 2.1.12 or earlier.
- Verify the settings update path includes proper WordPress nonce validation.
- Review recent plugin settings changes for unexpected modifications.
- Monitor vendor and Wordfence advisories for revised remediation details.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-352: User-session and phishing behavior lookup
Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupCVE-2026-3191 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- Medium
- CVSS
- 5.4 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L2.82.5Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
5.4MediumVector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Source materials
- CVE List V5 sourceCVE List V5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fe14b92b-1784-4083-9b9f-23d7f69a3215?source=cveCVE reference
- https://plugins.trac.wordpress.org/browser/minify-html-markup/tags/2.1.12/minify-html.php#L139CVE reference
- https://plugins.trac.wordpress.org/changeset/3486011/minify-html-markupCVE reference
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Cross-Site Request Forgery (CSRF)
Cross-Site Request Forgery (CSRF) represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
