Security readout for executives and security teams
Plain-English summary
CVE-2026-2991 lets an unauthenticated attacker bypass login in the WordPress KiviCare EHR plugin by abusing social login with only a patient email address. On affected clinic sites, this can expose patient medical records, appointments, prescriptions, and billing data. Sources also note authentication cookies may be set for non-patient users before a role check.
Executive priority
Treat as urgent for healthcare-facing WordPress sites. The vulnerability can enable unauthorized access to patient information without credentials, creating material privacy, operational, and regulatory exposure. Prioritize inventory, update verification, and log review.
Technical view
KiviCare <= 4.1.2 is vulnerable to CWE-287 authentication bypass in patientSocialLogin(). The function does not verify the social provider access token before authenticating a user. CVSS is 7.3, network-accessible, low complexity, no privileges, no user interaction. The issue is documented by Wordfence, CVE records, WordPress Trac code references, and changeset 3467409.
Likely exposure
Exposure is likely for WordPress sites running KiviCare – Clinic & Patient Management System (EHR) up to and including 4.1.2, especially where patient accounts exist. The business impact is elevated because the plugin handles clinical and billing workflows involving PII/PHI.
Exploitation context
No provided source or KEV listing confirms active exploitation. The described flaw is remotely reachable and does not require credentials or user interaction. Attackers would need a registered patient email address; sources state arbitrary social access-token values are accepted.
Researcher notes
The source bundle gives strong root-cause detail but incomplete release guidance. The CVE affected metadata appears inconsistent with the narrative, so rely on the title, description, Wordfence entry, and Trac references for version scope unless vendor guidance says otherwise.
Mitigation direction
- Identify all WordPress sites using the KiviCare EHR plugin.
- Upgrade KiviCare beyond 4.1.2 if a vendor-fixed release is available.
- Review WordPress plugin changelog and changeset 3467409 for the vendor fix.
- If immediate update is unavailable, consider disabling the plugin or affected social login feature.
- Rotate sessions and review account access after remediation.
Validation and detection
- Confirm installed KiviCare plugin version on every WordPress instance.
- Flag versions up to and including 4.1.2 as vulnerable.
- Verify the deployed code includes the vendor changes from changeset 3467409.
- Review logs for unusual patient logins, especially social-login events.
- Check for unexpected authentication cookies tied to failed role checks.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-287: Credential and account abuse lookup
Authentication and credential weaknesses can make valid-account abuse and credential telemetry useful review starting points. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupCredential and access behavior lookup
The CVE wording references authentication or credential exposure, so valid-account and credential-access review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
Open ATT&CK lookupCVE-2026-2991 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- High
- CVSS
- 7.3 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L3.93.4Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
7.3HighVector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Source materials
- CVE List V5 sourceCVE List V5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8d22448b-aa8e-4775-b7c5-e7bae94a3f6d?source=cveCVE reference
- https://plugins.trac.wordpress.org/browser/kivicare-clinic-management-system/trunk/app/controllers/api/AuthController.php#L1852CVE reference
- https://plugins.trac.wordpress.org/changeset/3467409/CVE reference
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Authentication
Improper Authentication represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
