LiveActive security incident?Get immediate response
CVE Record

CVE-2026-27968: Packistry accepts expired access tokens

Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected.

MediumCVSS 4.3Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

Packistry versions before 0.13.0 may still honor expired deploy tokens if the token has the right permission. This could let someone with an old token continue accessing package repository metadata or downloads after access should have ended.

Executive priority

Treat as a timely maintenance fix, especially if Packistry serves private packages. The business risk is unauthorized continued access to package artifacts by someone holding an old token, not broad unauthenticated compromise.

Technical view

RepositoryAwareController::authorize() checked token presence and ability but did not enforce expiration. The issue affects packistry/packistry before 0.13.0. Version 0.13.0 adds an explicit expiration check and tests for rejected expired deploy tokens. CVSS is 4.3, network exploitable, low complexity, privileges required, confidentiality impact low.

Likely exposure

Exposure is limited to organizations running self-hosted Packistry before 0.13.0 and using deploy tokens. Risk depends on whether expired deploy tokens exist and whether they were exposed to former users, automation, logs, or CI systems.

Exploitation context

No active exploitation is indicated in the provided sources, and the CVE is not marked KEV. Exploitation requires possession of an expired deploy token with the correct ability, so this is mainly a stale-credential access-control risk.

Researcher notes

Mapped to CWE-287 and CWE-613. The root cause is missing expiration enforcement in authorization logic. The public fix is commit 7740b48 and PR #276. Evidence does not show integrity or availability impact, exploit publication, or active abuse.

Mitigation direction

  • Upgrade Packistry to version 0.13.0 or later.
  • Review and revoke expired or unnecessary deploy tokens.
  • Check vendor advisory and release notes for any deployment-specific guidance.
  • Audit CI/CD and automation stores for old Packistry deploy tokens.

Validation and detection

  • Inventory Packistry instances and confirm versions are below or at least 0.13.0.
  • Review token records for expired deploy tokens that may still exist.
  • Confirm expired deploy tokens are rejected after upgrading.
  • Check repository access logs for use of expired deploy tokens, if logged.
Prepared
Confidence
high
Sources
5

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-287: Credential and account abuse lookup

Authentication and credential weaknesses can make valid-account abuse and credential telemetry useful review starting points. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cwe · low confidence lookup

CWE-613: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Credential and access behavior lookup

The CVE wording references authentication or credential exposure, so valid-account and credential-access review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-27968 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
4.3 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
4Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
4.3CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N2.81.4Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

4.3Medium
CVSS 3.1 vector shape for CVE-2026-27968Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
packistrypackistry< 0.13.0Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-287 · source CWE mapping

Improper Authentication

Improper Authentication represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.

CWE-613 · source CWE mapping

Insufficient Session Expiration

Insufficient Session Expiration represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.