LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2732: Enable Media Replace <= 4.1.7 - Improper Authorization to Authenticated (Author+) Arbitrary Attachment Change via Background Replace

The Enable Media Replace plugin for WordPress is vulnerable to unauthorized modification of data due to an improper capability check on the 'RemoveBackGroundViewController::load' function in all versions up to, and including, 4.1.7. This makes it possible for authenticated attackers, with Author-level access and above, to replace any attachment with a removed background attachment.

MediumCVSS 5.4Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

A flaw in the WordPress Enable Media Replace plugin lets logged-in users with Author privileges or higher replace attachments they should not control. This could let a lower-privileged content user alter images or other media assets, causing content integrity issues or broken site content.

Executive priority

Treat as a medium-priority web content integrity issue. Patch during the next normal maintenance window, sooner for sites with many content authors, external contributors, or business-critical media assets.

Technical view

CVE-2026-2732 is an improper authorization issue in RemoveBackGroundViewController::load in Enable Media Replace through 4.1.7. The CVSS 3.1 score is 5.4. An authenticated Author+ user can replace any attachment with a removed-background attachment due to insufficient capability checking.

Likely exposure

Exposure is limited to WordPress sites running Enable Media Replace version 4.1.7 or earlier where Author-level or higher accounts exist, especially if those accounts are numerous, shared, or assigned to external contributors.

Exploitation context

The CVE data rates exploitation as network-accessible, low complexity, and requiring low privileges with no user interaction. CISA KEV is false, and the provided sources do not state active exploitation. The attacker must already have an Author-or-higher WordPress account.

Researcher notes

The strongest evidence is the CVE description, Wordfence advisory, affected source locations, and patch commit/WordPress changeset. The structured affected-version field appears incomplete, so rely on the textual statement: all versions up to and including 4.1.7.

Mitigation direction

  • Identify WordPress sites using Enable Media Replace.
  • Upgrade the plugin beyond 4.1.7 if a fixed release is available.
  • Review the vendor commit and WordPress changeset for the authorization fix.
  • Limit Author-level accounts to trusted users only.
  • Remove or downgrade unnecessary contributor accounts until patched.

Validation and detection

  • Inventory installed Enable Media Replace versions across WordPress sites.
  • Confirm whether any site runs version 4.1.7 or earlier.
  • Review WordPress users with Author, Editor, or Administrator roles.
  • Check media library history for unexpected attachment replacements.
  • Verify the patched code includes stronger capability checks in the affected controller.
Prepared
Confidence
high
Sources
7

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-862: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2732 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
5.4 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
5Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
5.4CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L2.82.5Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

5.4Medium
CVSS 3.1 vector shape for CVE-2026-2732Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
shortpixelEnable Media Replace0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-862 · source CWE mapping

Missing Authorization

Missing Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.