LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2722: Stock Ticker <= 3.26.1 - Authenticated (Administrator+) Stored Cross-Site Scripting via Template

The Stock Ticker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.26.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

MediumCVSS 4.8Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-2722 is a stored cross-site scripting issue in the WordPress Stock Ticker plugin through version 3.26.1. An administrator-level user could save script content in plugin settings that later runs for visitors to affected pages. Business urgency is moderate because exploitation requires high privileges and user interaction, and the sources do not indicate active exploitation.

Executive priority

Treat as a moderate-priority hygiene issue. It is not currently reported as actively exploited, but vulnerable sites should be identified and updated or monitored promptly, especially where multiple administrators or external site managers have access.

Technical view

The issue is CWE-79 caused by insufficient input sanitization and output escaping in Stock Ticker admin settings, specifically template-related handling. It affects versions up to and including 3.26.1 only in multisite installations or where WordPress unfiltered_html is disabled. CVSS 3.1 is 4.8: AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N.

Likely exposure

Exposure is limited to WordPress sites running Stock Ticker <= 3.26.1 under multisite or with unfiltered_html disabled. The attacker needs administrator-level access or higher, so risk is greatest where admin accounts are shared, delegated, compromised, or used by third parties.

Exploitation context

The public source bundle does not show CISA KEV listing or active exploitation. Exploitation requires an authenticated administrator to store malicious script content and another user to access the affected page. Impact is mainly script execution in users' browsers, with possible confidentiality and integrity effects.

Researcher notes

Sources identify affected versions through 3.26.1 and reference WordPress Trac code and a changeset, but the bundle does not clearly name a fixed version. Avoid assuming broad exposure: the advisory limits impact to multisite or unfiltered_html-disabled installations and administrator-plus attackers.

Mitigation direction

  • Inventory WordPress sites using the Stock Ticker plugin.
  • Identify installations running Stock Ticker version 3.26.1 or earlier.
  • Check vendor or WordPress plugin guidance for an updated fixed release.
  • Update the plugin if a version newer than 3.26.1 is available and approved.
  • Restrict administrator access to trusted users only.
  • Review multisite and unfiltered_html configurations for affected deployments.

Validation and detection

  • Confirm plugin version from WordPress admin or asset inventory.
  • Determine whether the site is WordPress multisite.
  • Check whether unfiltered_html is disabled for relevant administrators.
  • Review Stock Ticker settings for unexpected template or script-like content.
  • Verify that admin access is limited and individually assigned.
  • Monitor vendor, Wordfence, and WordPress plugin pages for fix confirmation.
Prepared
Confidence
medium
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-79: User-session and phishing behavior lookup

Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2722 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
4.8 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
5Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
4.8CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N1.72.7Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

4.8Medium
CVSS 3.1 vector shape for CVE-2026-2722Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
urkekgStock Ticker0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-79 · source CWE mapping

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.