LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2583: Blocksy <= 2.1.30 - Authenticated (Contributor+) Stored Cross-Site Scripting via `blocksy_meta` Fields

The Blocksy theme for WordPress is vulnerable to Stored Cross-Site Scripting via the `blocksy_meta` metadata fields in all versions up to, and including, 2.1.30 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

MediumCVSS 6.4Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-2583 affects the Blocksy WordPress theme through version 2.1.30. A logged-in user with Contributor or higher privileges could store malicious script in page metadata. That script may run when someone views the affected page, creating risk to site users and administrators.

Executive priority

Treat as a timely WordPress hygiene issue, not an emergency based on available evidence. Prioritize sites with many content contributors, public registration, or weak account governance. Update and review access promptly to reduce stored XSS risk.

Technical view

The issue is stored cross-site scripting in Blocksy `blocksy_meta` fields caused by insufficient input sanitization and output escaping. It is network-accessible, low-complexity, requires low privileges, and has CVSS 3.1 score 6.4. The CVE maps to CWE-79 and affects versions up to and including 2.1.30.

Likely exposure

WordPress sites using the Blocksy theme at version 2.1.30 or earlier are the likely exposure, especially sites allowing Contributor-level accounts or above. Public sources do not indicate exposure for unrelated themes or plugins.

Exploitation context

The vulnerability requires an authenticated account with Contributor or higher permissions. The source bundle does not report known active exploitation, and the CVE is not listed as CISA KEV. Impact is mainly browser-side script execution against visitors to injected pages.

Researcher notes

The cited record identifies `blocksy_meta` metadata fields as the sink and attributes the issue to missing sanitization and escaping. Public evidence provided does not include exploit details or confirmation of exploitation in the wild. The WordPress changeset is relevant for remediation review.

Mitigation direction

  • Update Blocksy to a version newer than 2.1.30 if available.
  • Check official Blocksy and WordPress theme guidance for the fixed release.
  • Limit Contributor and higher roles to trusted users.
  • Review recent content changes by Contributor-level accounts.
  • Remove suspicious scripts from affected pages or metadata.

Validation and detection

  • Inventory WordPress sites using the Blocksy theme.
  • Confirm whether Blocksy version is 2.1.30 or earlier.
  • Review users with Contributor, Author, Editor, or Administrator roles.
  • Inspect relevant page metadata for unexpected script content.
  • Verify the theme is updated after remediation.
Prepared
Confidence
medium
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-79: User-session and phishing behavior lookup

Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2583 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
6.4 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
3Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
6.4CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N3.12.7Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

6.4Medium
CVSS 3.1 vector shape for CVE-2026-2583Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
creativethemeshqBlocksy0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-79 · source CWE mapping

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.