LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2480: WP Shortcodes Plugin — Shortcodes Ultimate <= 7.4.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'max_width' Shortcode Attribute

The WP Shortcodes Plugin — Shortcodes Ultimate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'max_width' attribute of the `su_box` shortcode in all versions up to, and including, 7.4.10 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

MediumCVSS 6.4Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-2480 affects the WordPress Shortcodes Ultimate plugin through version 7.4.10. A logged-in user with Contributor or higher rights could store malicious script in a shortcode attribute. That script may run for visitors or administrators who view the affected page, creating account, content, or session-risk concerns.

Executive priority

Treat as a near-term web publishing risk, not an emergency based on current sources. Prioritize sites with many contributors, public registration, or sensitive administrator sessions. Patch or restrict contributor access promptly.

Technical view

The issue is stored cross-site scripting in the `su_box` shortcode `max_width` attribute, caused by insufficient sanitization and output escaping. Wordfence rates it CVSS 6.4. It requires authenticated low-privileged access and impacts confidentiality and integrity with changed scope. WordPress Trac references show the relevant code and a later changeset.

Likely exposure

Exposure is limited to WordPress sites running Shortcodes Ultimate up to and including 7.4.10, especially where untrusted users have Contributor, Author, Editor, or Administrator access.

Exploitation context

The source bundle does not show CISA KEV listing or public active exploitation. Exploitation requires a valid site account with Contributor-level permissions or higher, then execution occurs when an injected page is accessed.

Researcher notes

Key evidence is Wordfence’s advisory, CVE metadata, and WordPress Trac code references. The bundle names affected versions through 7.4.10 and shows a changeset, but does not clearly state a fixed release version or exploitation in the wild.

Mitigation direction

  • Identify WordPress sites using Shortcodes Ultimate and record installed versions.
  • Prioritize updating any installation at or below 7.4.10 using official plugin guidance.
  • If no fixed release is available, restrict Contributor and higher access to trusted users.
  • Review shortcode usage in user-submitted content for suspicious `su_box` `max_width` values.
  • Monitor vendor, Wordfence, and WordPress plugin guidance for confirmed fixed-version details.

Validation and detection

  • Check plugin inventory for Shortcodes Ultimate versions up to and including 7.4.10.
  • Verify whether low-privileged users can create or edit shortcode-containing content.
  • Inspect recent posts and pages containing `su_box` shortcodes for abnormal attributes.
  • Compare installed plugin code with the referenced WordPress Trac changeset.
  • Confirm remediation by verifying the plugin is updated or access restrictions are enforced.
Prepared
Confidence
high
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-79: User-session and phishing behavior lookup

Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2480 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
6.4 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
4Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
6.4CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N3.12.7Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

6.4Medium
CVSS 3.1 vector shape for CVE-2026-2480Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
gn_themesWP Shortcodes Plugin — Shortcodes Ultimate0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-79 · source CWE mapping

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.