LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2448: Page Builder by SiteOrigin <= 2.33.5 - Authenticated (Contributor+) Local File Inclusion

The Page Builder by SiteOrigin plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.33.5 via the locate_template() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

HighCVSS 8.8Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

CVE-2026-2448 affects the WordPress plugin Page Builder by SiteOrigin through version 2.33.5. A logged-in user with Contributor-level access or higher may be able to make the site include local server files. In some conditions, this can expose sensitive data or lead to server-side PHP code execution.

Executive priority

Prioritize remediation for public WordPress sites with multiple content contributors or user-generated uploads. The vulnerability has high impact but requires authenticated access, so urgency depends on who holds Contributor-level accounts and whether upload paths are available.

Technical view

The issue is a local file inclusion vulnerability in Page Builder by SiteOrigin, tied to locate_template() use in the post loop widget code path. The CVE describes authenticated Contributor+ attackers including and executing arbitrary server files, including uploaded files that may otherwise be treated as safe. CVSS 3.1 is 8.8, CWE-22.

Likely exposure

Exposure is most relevant to WordPress sites running Page Builder by SiteOrigin version 2.33.5 or earlier, especially sites that allow Contributor-level users or higher and permit media uploads. Sites without untrusted authenticated users have lower practical exposure, but should still validate plugin versions.

Exploitation context

The CVE requires authenticated access with Contributor privileges or higher. The source bundle does not show CISA KEV listing or cited evidence of active exploitation. Impact may include access-control bypass, sensitive data exposure, or PHP code execution when includable files are present.

Researcher notes

Evidence is limited to the CVE record, Wordfence advisory, and WordPress plugin source reference. The supplied data does not include a confirmed fixed version, proof of exploitation, or KEV listing. Avoid assuming internet-scale exploitation without additional cited evidence.

Mitigation direction

  • Identify all WordPress sites using Page Builder by SiteOrigin.
  • Update the plugin to a version newer than 2.33.5 if available.
  • If no update is available, check SiteOrigin or WordPress plugin guidance.
  • Restrict Contributor-level access to trusted users only.
  • Review whether Contributors can upload files on affected sites.

Validation and detection

  • Confirm installed Page Builder by SiteOrigin versions across WordPress assets.
  • Flag any installation at version 2.33.5 or earlier.
  • Review user roles for Contributor or higher access.
  • Check whether untrusted users have media upload capability.
  • Monitor WordPress and web logs for suspicious template or file inclusion errors.
Prepared
Confidence
high
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-22: File access and web shell behavior lookup

File traversal and upload weaknesses can lead teams to review file, web shell, execution, and collection telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Execution behavior lookup

The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2448 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
8.8 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
3Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
8.8CVSS 3.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H2.85.9Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

8.8High
CVSS 3.1 vector shape for CVE-2026-2448Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
gpridayPage Builder by SiteOrigin0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-22 · source CWE mapping

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.