LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2432: CM Custom Reports <= 1.2.7 - Authenticated (Administrator+) Stored Cross-Site Scripting via Plugin Labels

The CM Custom Reports – Flexible reporting to track what matters most plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.2.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

MediumCVSS 4.4Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-2432 is a stored cross-site scripting issue in the WordPress plugin CM Custom Reports through version 1.2.7. An administrator-level user could save malicious script in plugin labels, causing it to run when someone views the affected page. The issue is limited to multisite installations or sites where unfiltered_html is disabled.

Executive priority

Treat this as a moderate, targeted WordPress plugin risk. It is not currently evidenced as exploited and requires administrator-level access, but it can matter in multisite environments or where admin roles are delegated broadly. Address during normal vulnerability remediation, faster for high-trust public sites.

Technical view

The vulnerability is CWE-79 caused by insufficient input sanitization and output escaping in admin settings, specifically plugin label handling referenced in GraphModule.php. It requires authenticated administrator-level privileges or higher. CVSS 3.1 is 4.4 with high privileges and high attack complexity, scope changed, and low confidentiality/integrity impact.

Likely exposure

Exposure is limited to WordPress sites using CM Custom Reports version 1.2.7 or earlier, especially multisite deployments or installations where unfiltered_html has been disabled. Single-site WordPress deployments with normal administrator unfiltered_html behavior may not be affected per the CVE description.

Exploitation context

No cited source in the provided bundle indicates active exploitation, and the CVE is not marked KEV. Abuse requires an authenticated administrator-level account, so this is most relevant where site administrators are numerous, delegated, compromised, or less trusted.

Researcher notes

The public record identifies stored XSS via admin settings and references GraphModule.php plus a WordPress trac changeset. The provided evidence does not include exploit details or a clearly named fixed plugin version. Validate exposure by version, multisite status, and unfiltered_html configuration before assigning urgency.

Mitigation direction

  • Inventory WordPress sites for CM Custom Reports installations and versions.
  • Prioritize multisite deployments and sites with unfiltered_html disabled.
  • Upgrade beyond version 1.2.7 if a vendor-fixed release is available.
  • If no fixed release is available, follow vendor guidance or disable the plugin.
  • Limit administrator-level access to trusted users only.
  • Review plugin settings for unexpected or suspicious label content.

Validation and detection

  • Confirm whether CM Custom Reports is installed on each WordPress site.
  • Record the installed plugin version and compare it with 1.2.7.
  • Check whether the WordPress deployment is multisite.
  • Check whether unfiltered_html is disabled for relevant administrators.
  • Review CM Custom Reports labels/settings for unexpected script-like content.
  • Monitor Wordfence, CVE, and WordPress plugin trac for fix confirmation.
Prepared
Confidence
high
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-79: User-session and phishing behavior lookup

Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2432 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
4.4 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
5Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
4.4CVSS 3.1MediumCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N1.32.7Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

4.4Medium
CVSS 3.1 vector shape for CVE-2026-2432Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
creativemindssolutionsCM Custom Reports – Flexible reporting to track what matters most0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-79 · source CWE mapping

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.