LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2430: Autoptimize <= 3.1.14 - Authenticated (Contributor+) Stored Cross-Site Scripting via Lazy-loaded Image Attributes

The Autoptimize plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the lazy-loading image processing in all versions up to, and including, 3.1.14. This is due to the use of an overly permissive regular expression in the `add_lazyload` function that replaces all occurrences of `\ssrc=` in image tags without limiting to the actual attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page by crafting an image tag where the `src` URL contains a space followed by `src=`, causing the regex to break the HTML structure and promote text inside attribute values into executable HTML attributes.

MediumCVSS 6.4Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-2430 affects the Autoptimize WordPress plugin through version 3.1.14. A logged-in user with Contributor-level access or higher could store malicious script in content that runs when others view the page. This is mainly a website integrity and account-risk issue, not a server takeover based on current sources.

Executive priority

Treat as a timely WordPress plugin maintenance item. Prioritize sites with many contributors, public submissions, or shared editorial access. The issue is moderate severity but can become more serious if an administrator views attacker-controlled content.

Technical view

The flaw is stored cross-site scripting in Autoptimize lazy-loaded image handling. An overly broad regex in add_lazyload processes occurrences of whitespace followed by src= inside image tags, allowing crafted markup to break attribute structure and create executable HTML attributes. CVSS is 6.4, with network access, low complexity, low privileges, changed scope, and low confidentiality/integrity impact.

Likely exposure

Exposure is limited to WordPress sites running Autoptimize up to and including 3.1.14, where untrusted or semi-trusted users can create posts or pages with Contributor-level privileges or higher.

Exploitation context

Sources do not indicate active exploitation, and the CVE is not listed as KEV. Exploitation requires authenticated content creation rights. Successful abuse could execute script in visitors’ browsers, potentially affecting administrators or other users who view injected content.

Researcher notes

The key root cause is regex-based transformation in lazy-loaded image handling, not generalized WordPress XSS. Evidence points to a code fix in the upstream GitHub commit and WordPress plugin changeset, but the bundle does not name a specific fixed version.

Mitigation direction

  • Inventory WordPress sites using Autoptimize and identify versions at or below 3.1.14.
  • Update Autoptimize to a vendor-fixed release newer than 3.1.14 when available.
  • If no update is available, follow vendor guidance and restrict Contributor-level content creation.
  • Review and reduce untrusted Contributor, Author, Editor, and Administrator accounts.
  • Consider disabling affected lazy-load image processing until vendor guidance is applied.

Validation and detection

  • Confirm installed Autoptimize versions across WordPress environments.
  • Check whether Autoptimize lazy-load image processing is enabled.
  • Review users with Contributor-level or higher posting permissions.
  • Audit recent contributed content for unusual image markup or unexpected script behavior.
  • Verify the installed code includes the vendor change referenced in the commit or WordPress changeset.
Prepared
Confidence
high
Sources
7

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-79: User-session and phishing behavior lookup

Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2430 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
6.4 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
6Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
6.4CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N3.12.7Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

6.4Medium
CVSS 3.1 vector shape for CVE-2026-2430Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
optimizingmattersAutoptimize0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-79 · source CWE mapping

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.