Security readout for executives and security teams
Plain-English summary
CVE-2026-2421 affects the ilGhera Carta Docente for WooCommerce WordPress plugin through version 1.5.0. A logged-in administrator could abuse a certificate deletion function to delete unintended server files. The main business risk is site outage or compromise if an administrator account is malicious or already compromised.
Executive priority
Treat as a targeted administrative-risk issue, not a broad unauthenticated emergency. Prioritize updates on sites with many admins, weak admin security, or high business impact from downtime.
Technical view
The plugin’s wccd-delete-certificate AJAX action insufficiently validates the cert parameter before file deletion, creating a CWE-22 path traversal issue. Wordfence rates it CVSS 6.5. Required privileges are high: Administrator-level access or above. Arbitrary file deletion could include sensitive WordPress files, potentially enabling takeover or remote code execution depending on environment.
Likely exposure
Exposure is limited to WordPress sites running ilGhera Carta Docente for WooCommerce version 1.5.0 or earlier, where an attacker has Administrator-level access or controls such an account.
Exploitation context
The provided sources do not show CISA KEV listing or active exploitation. Exploitation requires authenticated Administrator-level access, so risk rises where admin accounts are shared, weakly protected, or already compromised.
Researcher notes
Key evidence comes from Wordfence and WordPress plugin Trac references. The vulnerable path involves the cert parameter in an admin AJAX deletion action. Sources indicate affected versions through 1.5.0 and show later code, but no public exploitation evidence is provided.
Mitigation direction
- Identify sites using ilGhera Carta Docente for WooCommerce.
- Upgrade affected installations beyond version 1.5.0 if available through official plugin channels.
- If unable to update, consult vendor guidance and restrict administrator access.
- Enforce MFA and strong credential controls for WordPress administrators.
- Review backups and recovery procedures for critical WordPress files.
Validation and detection
- Inventory installed plugin versions across WordPress sites.
- Confirm no installation is running version 1.5.0 or earlier.
- Review administrator accounts for unauthorized or stale access.
- Check web and WordPress logs for suspicious certificate deletion activity.
- Verify file integrity for critical WordPress configuration files.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-22: File access and web shell behavior lookup
File traversal and upload weaknesses can lead teams to review file, web shell, execution, and collection telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupExecution behavior lookup
The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
Open ATT&CK lookupFile access behavior lookup
The CVE wording references file access or upload behavior, so file telemetry and web shell review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
Open ATT&CK lookupCVE-2026-2421 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- Medium
- CVSS
- 6.5 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H1.25.2Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
6.5MediumVector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Source materials
- CVE List V5 sourceCVE List V5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7aab1307-7fb5-46fb-ae12-087dce3086fc?source=cveCVE reference
- https://plugins.trac.wordpress.org/browser/wc-carta-docente/trunk/includes/class-wccd-admin.php#L88CVE reference
- https://plugins.trac.wordpress.org/browser/wc-carta-docente/tags/1.4.7/includes/class-wccd-admin.php#L88CVE reference
- https://plugins.trac.wordpress.org/browser/wc-carta-docente/tags/1.5.1/includes/class-wccd-admin.php#L80CVE reference
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
