LiveActive security incident?Get immediate response
CVE Record

CVE-2026-23857: Dell Update Package (DUP) Framework, versions 23.12.00 through 24.12.00, contains an Improper Handling of I...

Dell Update Package (DUP) Framework, versions 23.12.00 through 24.12.00, contains an Improper Handling of Insufficient Permissions or Privileges vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of privileges.

HighCVSS 8.2Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

CVE-2026-23857 is a high-severity local privilege escalation issue in Dell Update Package Framework versions 23.12.00 through 24.12.00. An attacker who already has low-privileged local access may gain higher privileges, with potential confidentiality, integrity, and availability impact.

Executive priority

Treat as a high-priority patching item for managed Dell environments, especially systems with multiple local users or privileged operational roles. It is not described as remotely exploitable, but it can materially worsen compromise after initial access.

Technical view

The vulnerability is CWE-280: improper handling of insufficient permissions or privileges. CVSS 3.1 is 8.2, with local attack vector, low complexity, low privileges required, user interaction required, changed scope, and high CIA impact. The CVE record lists Dell Update Package Framework 25.02.00 as unaffected.

Likely exposure

Systems that have Dell Update Package Framework versions 23.12.00 through 24.12.00 installed are the likely exposure. Risk is highest where untrusted or broadly provisioned local users can access affected systems.

Exploitation context

The source data does not indicate active exploitation, and the CVE is not listed as KEV. Exploitation requires local access, low privileges, and user interaction, so this is mainly a post-access privilege escalation risk rather than a remote entry point.

Researcher notes

The provided source bundle has a wording mismatch: the description names versions 23.12.00 through 24.12.00 as vulnerable, while the affected entry lists 25.02.00 with default status unaffected. Use Dell advisory DSA-2026-081 as the authoritative remediation reference.

Mitigation direction

  • Review Dell advisory DSA-2026-081 for official remediation guidance.
  • Upgrade affected Dell DUP Framework installations to a Dell-listed unaffected or fixed version.
  • Prioritize systems with shared users, helpdesk access, or high-value administrative workflows.
  • Limit unnecessary local user access on systems using affected DUP Framework versions.
  • Monitor for unusual local privilege escalation or update-package activity.

Validation and detection

  • Inventory Dell Update Package Framework versions across managed endpoints and servers.
  • Flag versions 23.12.00 through 24.12.00 as potentially vulnerable.
  • Verify whether version 25.02.00 or later is approved by Dell guidance.
  • Confirm remediation against Dell advisory DSA-2026-081, not only asset inventory data.
  • Check vulnerability scanner detections against the CVE record and vendor advisory.
Prepared
Confidence
medium
Sources
3

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · low confidence lookup

CWE-280: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-23857 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
8.2 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
2Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
8.2CVSS 3.1HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H1.56Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

8.2High
CVSS 3.1 vector shape for CVE-2026-23857Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
DellUpdate Package25.02.00unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-280 · source CWE mapping

Improper Handling of Insufficient Permissions or Privileges

Improper Handling of Insufficient Permissions or Privileges represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.