LiveActive security incident?Get immediate response
CVE Record

CVE-2026-23856: Dell iDRAC Service Module (iSM) for Windows, versions prior to 6.0.3.1, and Dell iDRAC Service Module (iSM)...

Dell iDRAC Service Module (iSM) for Windows, versions prior to 6.0.3.1, and Dell iDRAC Service Module (iSM) for Linux, versions prior to 5.4.1.1, contain an Improper Access Control vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of privileges.

HighCVSS 7.8Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

CVE-2026-23856 is a Dell iDRAC Service Module vulnerability that can let a low-privileged local user gain higher privileges. It affects iSM for Windows before 6.0.3.1 and iSM for Linux before 5.4.1.1. This matters most on servers where local accounts, administrators, or workloads could be abused after initial access.

Executive priority

Treat as a high-priority server hygiene issue, especially for sensitive Dell-managed infrastructure. It is not described as remotely exploitable, but it can increase damage after an attacker gains a foothold. Prioritize updating affected servers during the next urgent maintenance window.

Technical view

The issue is Improper Access Control (CWE-284) in Dell iDRAC Service Module. CVSS 3.1 is 7.8, with local attack vector, low complexity, low privileges required, no user interaction, and high confidentiality, integrity, and availability impact. The CVE record identifies affected Windows and Linux iSM versions prior to the fixed releases.

Likely exposure

Exposure is limited to systems running Dell iDRAC Service Module for Windows before 6.0.3.1 or Linux before 5.4.1.1. The attacker needs local access and low privileges, so internet-facing exploitability is not indicated by the provided sources.

Exploitation context

No active exploitation is indicated in the provided sources, and the CVE is not marked as CISA KEV. The realistic scenario is post-compromise privilege escalation by someone who already has local access to an affected server.

Researcher notes

The public data identifies the weakness class, CVSS vector, local privilege-escalation conditions, and fixed version thresholds. The bundle does not provide technical root cause detail, proof-of-concept status, or exploit indicators. Avoid assuming broader Dell iDRAC firmware exposure; this CVE is for iDRAC Service Module.

Mitigation direction

  • Upgrade Dell iDRAC Service Module for Windows to 6.0.3.1 or later.
  • Upgrade Dell iDRAC Service Module for Linux to 5.4.1.1 or later.
  • Review Dell advisory DSA-2026-077 for environment-specific update guidance.
  • Restrict local interactive and service account access on affected servers until updated.

Validation and detection

  • Inventory servers running Dell iDRAC Service Module.
  • Check installed iSM version on Windows and Linux hosts.
  • Flag Windows iSM versions earlier than 6.0.3.1.
  • Flag Linux iSM versions earlier than 5.4.1.1.
  • Confirm remediation against Dell advisory DSA-2026-077.
Prepared
Confidence
high
Sources
3

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-284: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-23856 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
7.8 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
2Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
7.8CVSS 3.1HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H1.85.9Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

7.8High
CVSS 3.1 vector shape for CVE-2026-23856Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
DelliDRAC Service ModuleN/A, N/Aunaffected
DelliDRAC Service Module for LinuxN/Aunaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-284 · source CWE mapping

Improper Access Control

Improper Access Control represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.