LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2371: Greenshift <= 12.8.3 - Missing Authorization to Unauthenticated Private Reusable Block Disclosure via 'gspb_el_reusable_load'

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 12.8.3. This is due to missing authorization and post status validation in the `gspb_el_reusable_load()` AJAX handler. The handler accepts an arbitrary `post_id` parameter and renders the content of any `wp_block` post without checking `current_user_can('read_post', $post_id)` or verifying the post status. Combined with the nonce being exposed to unauthenticated users on any public page using the `[wp_reusable_render]` shortcode with `ajax="1"`, this makes it possible for unauthenticated attackers to retrieve the rendered HTML content of private, draft, or password-protected reusable blocks.

MediumCVSS 5.3Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-2371 can let an unauthenticated visitor view content from private, draft, or password-protected WordPress reusable blocks in the Greenshift plugin. The business impact is limited to information disclosure, but sensitive unpublished page fragments, campaign content, or internal notes stored in reusable blocks could be exposed.

Executive priority

Treat as a near-term web content confidentiality issue. Prioritize public WordPress sites that use Greenshift for marketing, member, partner, or pre-release content. It is not currently sourced as actively exploited, but unauthenticated access makes delayed remediation undesirable.

Technical view

Greenshift versions up to and including 12.8.3 have missing authorization and post-status validation in the gspb_el_reusable_load AJAX handler. An exposed nonce on public pages using the wp_reusable_render shortcode with ajax enabled can allow unauthenticated rendering of arbitrary wp_block posts. CVSS is 5.3, CWE-862.

Likely exposure

Exposure is most likely on WordPress sites running Greenshift <= 12.8.3 that use AJAX reusable block rendering on public pages. Sites that do not store sensitive content in reusable blocks have lower impact, but should still update or validate configuration.

Exploitation context

The source bundle does not show CISA KEV listing or cited evidence of active exploitation. The issue is remotely reachable, requires no authentication, and has low attack complexity, but impact is limited to confidentiality of reusable block content.

Researcher notes

The public description attributes the flaw to absent current_user_can read_post checks and missing post-status validation. The WordPress.org changeset is relevant for code review. Evidence provided does not fully establish exploitation in the wild or a specific fixed release number.

Mitigation direction

  • Inventory WordPress sites using the Greenshift plugin.
  • Update Greenshift to a version newer than 12.8.3 if available.
  • Review vendor and WordPress.org plugin guidance for the official fix.
  • Remove sensitive content from private, draft, or password-protected reusable blocks.
  • Disable AJAX reusable block rendering where not required.

Validation and detection

  • Check Greenshift plugin versions across all WordPress sites.
  • Identify public pages using wp_reusable_render with AJAX enabled.
  • Review reusable blocks for sensitive unpublished or protected content.
  • Check web logs for unusual unauthenticated requests referencing gspb_el_reusable_load.
  • Confirm the installed plugin includes authorization and post-status checks.
Prepared
Confidence
medium
Sources
7

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-862: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Credential and access behavior lookup

The CVE wording references authentication or credential exposure, so valid-account and credential-access review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2371 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
5.3 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
5Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
5.3CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N3.91.4Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

5.3Medium
CVSS 3.1 vector shape for CVE-2026-2371Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
wpsoulGreenshift – animation and page builder blocks0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-862 · source CWE mapping

Missing Authorization

Missing Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.