Security readout for executives and security teams
Plain-English summary
CVE-2026-23523 affects the Dive desktop app before version 0.13.0. A malicious deep link could cause Dive to install an attacker-controlled MCP server configuration, potentially leading to local command execution. The flaw is critical because exploitation can compromise the user’s machine, but the available sources indicate user interaction is required.
Executive priority
Treat as urgent for teams using Dive. The issue can lead to full local compromise after user interaction. Prioritize rapid upgrade and exposure discovery, but avoid assuming active exploitation unless new evidence emerges.
Technical view
Dive versions before 0.13.0 insufficiently confirm MCP server installation via crafted deep links. The issue is classified as CWE-94 and scored CVSS 9.7 with network attack vector, low complexity, no privileges, and required user interaction. Scope changes, with high confidentiality, integrity, and availability impact. The vendor advisory states the issue is fixed in 0.13.0.
Likely exposure
Organizations are exposed where employees run OpenAgentPlatform Dive desktop versions earlier than 0.13.0, especially if users can open external links that invoke Dive deep-link handling.
Exploitation context
The source bundle does not show CISA KEV listing or confirmed active exploitation. Exploitation requires convincing a user to open a crafted deep link, after which Dive may install an attacker-controlled MCP configuration leading to local command execution.
Researcher notes
Public sources identify the vulnerable behavior, affected versions, CVSS vector, CWE-94, and fixing commit. They do not provide evidence of exploitation in the wild. Review the advisory and commit for implementation details without relying on unverified exploit claims.
Mitigation direction
- Upgrade OpenAgentPlatform Dive to version 0.13.0 or later.
- Identify endpoints running Dive versions earlier than 0.13.0.
- Review vendor advisory and release notes for any additional guidance.
- Warn users not to open untrusted Dive deep links until upgraded.
Validation and detection
- Confirm installed Dive version is 0.13.0 or later.
- Check software inventory for Dive desktop installations below 0.13.0.
- Review endpoint telemetry for unexpected MCP server configuration changes.
- Monitor for suspicious local command execution from Dive-related processes.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-94: Code execution behavior lookup
Code execution and unsafe deserialization weaknesses often justify reviewing execution behavior and process telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupExecution behavior lookup
The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
Open ATT&CK lookupCVE-2026-23523 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- Critical
- CVSS
- 9.7 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H2.86Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
9.7CriticalVector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Source materials
- CVE List V5 sourceCVE List V5
- https://github.com/OpenAgentPlatform/Dive/security/advisories/GHSA-pjj5-f3wm-f9m8CVE reference · x_refsource_CONFIRM
- https://github.com/OpenAgentPlatform/Dive/commit/a5162ac9eff366d8ea1215b8a47139a81a55a779CVE reference · x_refsource_MISC
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Control of Generation of Code ('Code Injection')
Improper Control of Generation of Code ('Code Injection') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
