Security readout for executives and security teams
Plain-English summary
CVE-2026-22871 affects Datadog GuardDog, a CLI tool used to inspect PyPI packages. Before version 2.7.1, a malicious package could escape GuardDog’s extraction directory and overwrite files on the system running the scan, potentially causing remote code execution. Organizations using GuardDog in developer machines or CI pipelines should prioritize updating.
Executive priority
Treat as high priority for teams using GuardDog in automation. The vulnerable tool is security-related and may process hostile packages by design, increasing business risk if CI runners or developer environments are compromised.
Technical view
GuardDog versions before 2.7.1 contain a CWE-22 path traversal flaw in safe_extract(). When GuardDog processes a malicious PyPI package, archive paths can write outside the intended extraction directory. The advisory states this can lead to arbitrary file overwrite and remote code execution. CVSS v4.0 score is 8.7, with network attack vector, low complexity, no privileges, and user interaction required.
Likely exposure
Exposure is likely where GuardDog versions below 2.7.1 are installed and used to scan untrusted or third-party PyPI packages, especially in CI/CD, security automation, or developer workstations.
Exploitation context
The sources do not report active exploitation, and this CVE is not marked KEV. Exploitation requires GuardDog to process a malicious PyPI package. Impact is significant because the vulnerable system may overwrite arbitrary files and potentially execute attacker-controlled effects.
Researcher notes
The public sources identify the vulnerable function, affected version range, CVSS vector, CWE-22 classification, and fixing release. They do not provide evidence of exploitation in the wild. Further assessment should focus on where GuardDog extracts packages and the privileges of those execution environments.
Mitigation direction
- Upgrade Datadog GuardDog to version 2.7.1 or later.
- Identify CI jobs, developer systems, and security tooling containers using GuardDog.
- Avoid scanning untrusted packages with vulnerable GuardDog versions until upgraded.
- Review the GitHub advisory and vendor commit for implementation details.
Validation and detection
- Check installed GuardDog versions across workstations, CI runners, and containers.
- Confirm GuardDog is version 2.7.1 or later.
- Search build and security pipelines for GuardDog usage.
- Review recent GuardDog scan activity involving untrusted PyPI packages.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-22: File access and web shell behavior lookup
File traversal and upload weaknesses can lead teams to review file, web shell, execution, and collection telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupExecution behavior lookup
The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
Open ATT&CK lookupFile access behavior lookup
The CVE wording references file access or upload behavior, so file telemetry and web shell review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
Open ATT&CK lookupCVE-2026-22871 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- High
- CVSS
- 8.7 (4.0)
- Known Exploited
- No
- Published
Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N——Primary CVE scoreVulnerability scoring details
Base CVSS 4.0 score
8.7HighVector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Source materials
- CVE List V5 sourceCVE List V5
- https://github.com/DataDog/guarddog/security/advisories/GHSA-xg9w-vg3g-6m68CVE reference · x_refsource_CONFIRM
- https://github.com/DataDog/guarddog/commit/9aa6a725b2c71d537d3c18d1c15621395ebb879cCVE reference · x_refsource_MISC
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
