LiveActive security incident?Get immediate response
CVE Record

CVE-2026-22611: AWS SDK for .NET V4 adopted defense in depth enhancement for region parameter value

AWS SDK for .NET works with Amazon Web Services to help build scalable solutions with Amazon S3, Amazon DynamoDB, Amazon Glacier, and more. From versions 4.0.0 to before 4.0.3.3, Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value. This issue has been patched in version 4.0.3.3.

LowCVSS 3.7Not KEV-listedUpdated
Glexia's TakeAutomated analysislow

Security readout for executives and security teams

Plain-English summary

CVE-2026-22611 affects AWS SDK for .NET V4 versions 4.0.0 through before 4.0.3.3. If someone can control the SDK environment’s region input, AWS API calls may be routed to invalid or non-AWS hosts. AWS describes the update as a defense-in-depth enhancement. The listed severity is low.

Executive priority

Treat as routine but real dependency hygiene. Prioritize updates for .NET services that handle sensitive AWS interactions or allow broad configuration changes. The public data indicates low severity and no confirmed exploitation, but the affected version range should be removed during normal patch cycles.

Technical view

The issue is improper input validation of specific region parameter values in aws-sdk-net. An actor with access to the SDK’s runtime environment could set an invalid region value, causing customer applications to route AWS API calls to non-existent or non-AWS hosts. Patched version is 4.0.3.3. CVSS 3.1 score is 3.7, vector AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N.

Likely exposure

Exposure is limited to applications using AWS SDK for .NET V4 versions >=4.0.0 and <4.0.3.3 where the region input can be influenced through environment or configuration. Applications on earlier major versions or 4.0.3.3 and later are not identified as affected in the provided sources.

Exploitation context

The sources do not report active exploitation, and the CVE is not listed as KEV. Practical abuse appears to require the ability to affect the environment or configuration used by the SDK’s region input. The CVSS rating indicates high attack complexity and low confidentiality impact only.

Researcher notes

This is classified as CWE-20 with a low CVSS score. The key research question is whether any application exposes region configuration to less-trusted users or automation. Sources characterize the fix as defense-in-depth and do not provide public exploitation details. Avoid assuming broader AWS service compromise from this CVE alone.

Mitigation direction

  • Upgrade aws-sdk-net to version 4.0.3.3 or later.
  • Review vendor advisory for any updated AWS guidance.
  • Restrict who can modify application environment variables and configuration.
  • Validate deployment pipelines do not inject untrusted region values.

Validation and detection

  • Inventory .NET applications using AWS SDK for .NET V4.
  • Confirm package versions are not >=4.0.0 and <4.0.3.3.
  • Review configuration sources for SDK region values.
  • Check change control around environment and deployment configuration access.
Prepared
Confidence
high
Sources
3

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · low confidence lookup

CWE-20: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-22611 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Low
CVSS
3.7 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
2Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
3.7CVSS 3.1LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N2.21.4Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

3.7Low
CVSS 3.1 vector shape for CVE-2026-22611Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone

Source materials

Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
awsaws-sdk-net>= 4.0.0, < 4.0.3.3Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-20 · source CWE mapping

Improper Input Validation

Improper Input Validation represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.