LiveActive security incident?Get immediate response
CVE Record

CVE-2026-22603: OpenProject has no protection against brute-force attacks in the Change Password function

OpenProject is an open-source, web-based project management software. Prior to version 16.6.2, OpenProject’s unauthenticated password-change endpoint (/account/change_password) was not protected by the same brute-force safeguards that apply to the normal login form. In affected versions, an attacker who can guess or enumerate user IDs can send unlimited password-change requests for a given account without triggering lockout or other rate-limiting controls. This allows automated password-guessing (e.g., with wordlists of common passwords) against valid accounts. Successful guessing results in full account compromise for the targeted user and, depending on that user’s role, can lead to further privilege escalation inside the application. This issue has been patched in version 16.6.2. Those who are unable to upgrade may apply the patch manually.

MediumCVSS 6.9Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

OpenProject versions before 16.6.2 allowed attackers to repeatedly try password changes without the usual brute-force protections. If an attacker knows or guesses a valid user ID, they could automate password guessing and take over that account. Business impact depends on the compromised user’s role and permissions inside OpenProject.

Executive priority

Treat as a near-term remediation item for any exposed OpenProject instance. It is not rated critical and has no confirmed active exploitation in the provided sources, but successful abuse can result in account takeover and project data exposure or manipulation.

Technical view

CVE-2026-22603 is a CWE-307 improper restriction of excessive authentication attempts affecting OpenProject before 16.6.2. The unauthenticated password-change flow lacked the brute-force safeguards applied to normal login. CVSS v4.0 is 6.9. Successful guessing can compromise user accounts and may enable additional in-application privilege escalation depending on role.

Likely exposure

Organizations running OpenProject below 16.6.2 are exposed, especially internet-facing deployments or environments where user IDs can be guessed or enumerated. The issue is in OpenProject itself; no other affected products are identified in the provided sources.

Exploitation context

The source bundle does not indicate CISA KEV listing or confirmed active exploitation. Exploitation requires guessing or enumerating a valid user ID and successfully guessing that user’s password through repeated attempts.

Researcher notes

The advisory states the vulnerable password-change endpoint lacked normal login brute-force protections. Public sources identify the fix in 16.6.2 and a related pull request and commit. Evidence is sufficient for affected-version and remediation guidance, but no public exploitation evidence is provided in the bundle.

Mitigation direction

  • Upgrade OpenProject to version 16.6.2 or later.
  • If upgrade is not possible, apply the vendor-provided patch manually.
  • Review vendor advisory and release notes before production rollout.
  • Prioritize accounts with elevated OpenProject permissions for password review.

Validation and detection

  • Inventory all OpenProject instances and record running versions.
  • Confirm affected instances are upgraded to 16.6.2 or later.
  • Verify the vendor patch is applied where upgrades are deferred.
  • Review authentication-related logs for unusual password-change attempt volume.
Prepared
Confidence
high
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · low confidence lookup

CWE-307: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Credential and access behavior lookup

The CVE wording references authentication or credential exposure, so valid-account and credential-access review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
description · low confidence lookup

Privilege behavior lookup

The CVE wording references privilege impact, so privilege escalation and authorization behavior review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-22603 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
6.9 (4.0)
Known Exploited
No
Published

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
5Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
6.9CVSS 4.0MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N——Primary CVE score

Vulnerability scoring details

Base CVSS 4.0 score

6.9Medium
CVSS 4.0 vector shape for CVE-2026-22603Attack VectorAttack ComplexityAttack RequirementsPrivileges RequiredUser InteractionVS ConfidentialityVS IntegrityVS AvailabilitySS ConfidentialitySS IntegritySS Availability

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Attack Requirements
NonePresent
Privileges Required
NoneLowHigh
User Interaction
NonePassiveActive
VS Confidentiality
HighLowNone
VS Integrity
HighLowNone
VS Availability
HighLowNone
SS Confidentiality
HighLowNone
SS Integrity
HighLowNone
SS Availability
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
opfopenproject< 16.6.2Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-307 · source CWE mapping

Improper Restriction of Excessive Authentication Attempts

Improper Restriction of Excessive Authentication Attempts represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.