LiveActive security incident?Get immediate response
CVE Record

CVE-2026-22594: Ghost has Staff 2FA bypass

Ghost is a Node.js content management system. In versions 5.105.0 through 5.130.5 and 6.0.0 through 6.10.3, a vulnerability in Ghost's 2FA mechanism allows staff users to skip email 2FA. This issue has been patched in versions 5.130.6 and 6.11.0.

HighCVSS 8.1Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

Ghost sites running affected 5.x or 6.x versions may not enforce email-based two-factor authentication for staff users. An attacker still needs staff-level access, but bypassing 2FA can turn a compromised staff password into access to sensitive publishing or administrative functions. Patched versions are available.

Executive priority

Treat as a near-term patching priority for Ghost sites with staff access enabled, especially public-facing publishing platforms. This is not a no-login takeover issue, but it weakens a key protection against compromised staff credentials.

Technical view

CVE-2026-22594 is an authentication flaw in Ghost’s staff 2FA mechanism, classified as CWE-287. Affected ranges are 5.105.0 through before 5.130.6 and 6.0.0 through before 6.11.0. CVSS 3.1 is 8.1 with network access, low complexity, and low privileges required.

Likely exposure

Exposure is limited to Ghost deployments in the affected version ranges with staff accounts using email 2FA. Internet-facing Ghost admin interfaces increase practical risk. Ghost(Pro) and self-hosted status are not distinguished in the provided sources, so validate actual deployed versions.

Exploitation context

The provided sources do not report active exploitation, and the CVE is not marked in CISA KEV. The vulnerability requires an authenticated staff user context, so the main concern is account compromise, weak passwords, reused credentials, or malicious insiders bypassing the expected 2FA check.

Researcher notes

Public details identify a staff email 2FA bypass but do not provide exploit indicators in the supplied bundle. Review the GitHub advisory and linked commits for implementation-level changes. Avoid assuming broader MFA methods or products are affected without vendor confirmation.

Mitigation direction

  • Upgrade Ghost 5.x deployments to 5.130.6 or later.
  • Upgrade Ghost 6.x deployments to 6.11.0 or later.
  • Prioritize instances with internet-accessible staff login pages.
  • Review vendor advisory and release guidance before applying changes.
  • If immediate upgrade is delayed, restrict staff admin access where feasible.

Validation and detection

  • Inventory all Ghost instances and record exact versions.
  • Check whether versions fall within the affected 5.x or 6.x ranges.
  • Confirm upgraded instances report 5.130.6, 6.11.0, or later.
  • Verify staff authentication settings after upgrade.
  • Review staff account lists for unnecessary or stale access.
Prepared
Confidence
high
Sources
5

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-287: Credential and account abuse lookup

Authentication and credential weaknesses can make valid-account abuse and credential telemetry useful review starting points. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-22594 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
8.1 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
4Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
8.1CVSS 3.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N2.85.2Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

8.1High
CVSS 3.1 vector shape for CVE-2026-22594Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
TryGhostGhost>= 6.0.0, < 6.11.0, >= 5.105.0, < 5.130.6Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-287 · source CWE mapping

Improper Authentication

Improper Authentication represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.