LiveActive security incident?Get immediate response
CVE Record

CVE-2026-22252: LibreChat MCP Stdio Remote Command Execution

LibreChat is a ChatGPT clone with additional features. Prior to v0.8.2-rc2, LibreChat's MCP stdio transport accepts arbitrary commands without validation, allowing any authenticated user to execute shell commands as root inside the container through a single API request. This vulnerability is fixed in v0.8.2-rc2.

CriticalCVSS 9.1Not KEV-listedUpdated
Glexia's TakeAutomated analysiscritical

Security readout for executives and security teams

Plain-English summary

LibreChat versions before v0.8.2-rc2 have a critical flaw where an authenticated user can make the MCP stdio feature run arbitrary shell commands as root inside the container. This can compromise confidentiality, integrity, and availability of the LibreChat deployment. The vendor advisory says v0.8.2-rc2 fixes the issue.

Executive priority

Treat as urgent for any production LibreChat deployment. Patch quickly, reduce access while validating, and assess whether container-contained root command execution could expose business data, credentials, or connected systems.

Technical view

CVE-2026-22252 is an authorization/control weakness in LibreChat MCP stdio transport. Before v0.8.2-rc2, arbitrary commands are accepted without validation, enabling authenticated remote command execution as root within the container via a single API request. CVSS is 9.1 with network attack vector, low complexity, no user interaction, changed scope, and high impact.

Likely exposure

Organizations running LibreChat before v0.8.2-rc2 are exposed, especially if untrusted or broad user populations can authenticate. The documented execution context is root inside the container; broader host impact depends on container configuration, mounted secrets, volumes, and runtime privileges.

Exploitation context

The source bundle does not show CISA KEV listing or public active exploitation evidence. Exploitation requires authentication according to the advisory, but the described impact is severe because a single API request can execute shell commands inside the container.

Researcher notes

The advisory identifies affected versions as LibreChat before v0.8.2-rc2 and CWE-285. The commit reference likely contains the validation change, but this take avoids exploit details. No evidence in the provided sources confirms in-the-wild exploitation.

Mitigation direction

  • Upgrade LibreChat to v0.8.2-rc2 or later.
  • Review the GitHub advisory for any updated vendor guidance.
  • Restrict LibreChat access to trusted users until patched.
  • Review container privileges, mounted volumes, and exposed secrets.
  • Rotate credentials exposed to the LibreChat container if compromise is suspected.

Validation and detection

  • Inventory LibreChat deployments and record running versions.
  • Confirm all instances are v0.8.2-rc2 or later.
  • Check whether MCP stdio transport is enabled or reachable.
  • Review authentication logs for unusual user activity.
  • Inspect container logs for unexpected command execution indicators.
Prepared
Confidence
high
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · low confidence lookup

CWE-285: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Container behavior lookup

The affected technology mentions containers, so container-specific ATT&CK technique review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-22252 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Critical
CVSS
9.1 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
3Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
9.1CVSS 3.1CriticalCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H2.36Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

9.1Critical
CVSS 3.1 vector shape for CVE-2026-22252Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
danny-avilaLibreChat< v0.8.2-rc2Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-285 · source CWE mapping

Improper Authorization

Improper Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.