Security readout for executives and security teams
Plain-English summary
CVE-2026-22250 affects wlc, the Weblate command-line client. Before version 1.17.0, some specially crafted URLs could cause SSL certificate verification to be skipped. This could expose limited confidentiality if a user is tricked into using such a URL. The published severity is low, and the issue is fixed in wlc 1.17.0.
Executive priority
Treat as a routine remediation item unless wlc is widely used in sensitive automation. The issue is low severity, but upgrading is straightforward and reduces avoidable TLS trust risk in developer or localization workflows.
Technical view
The issue is a CWE-295 improper certificate validation flaw in WeblateOrg wlc versions before 1.17.0. The CVSS 3.1 score is 2.5, with local attack vector, high complexity, low privileges required, user interaction required, and low confidentiality impact. Vendor references identify the fix in pull request 1097 and commit a513864ec4daad00146e6d6e039559726e256fa3.
Likely exposure
Exposure is limited to environments using WeblateOrg wlc versions earlier than 1.17.0. Risk is most relevant where users or automation run wlc against untrusted, externally supplied, or unusual Weblate API URLs.
Exploitation context
The source bundle does not indicate active exploitation, and KEV status is false. Exploitation requires user interaction and a crafted URL scenario. The impact described is limited confidentiality exposure from skipped SSL verification, not integrity or availability compromise.
Researcher notes
Public sources describe the condition at a high level only: crafted URLs may skip SSL verification before 1.17.0. No exploit details, active exploitation evidence, or broader product impact are provided. Analysis should stay scoped to WeblateOrg wlc and the referenced fix.
Mitigation direction
- Upgrade WeblateOrg wlc to version 1.17.0 or later.
- Review automation that invokes wlc with externally supplied URLs.
- Prefer trusted, validated Weblate API endpoints in scripts and documentation.
- Monitor the vendor advisory for any additional guidance.
Validation and detection
- Inventory systems and developer environments with wlc installed.
- Confirm installed wlc versions are 1.17.0 or later.
- Identify CI jobs or scripts that call wlc.
- Review whether wlc URLs can be supplied by untrusted users.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-295: Exact CWE lookup
Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupCVE-2026-22250 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- Low
- CVSS
- 2.5 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N0.81.4Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
2.5LowVector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
Source materials
- CVE List V5 sourceCVE List V5
- https://github.com/WeblateOrg/wlc/security/advisories/GHSA-2mmv-7rrp-g8xhCVE reference · x_refsource_CONFIRM
- https://github.com/WeblateOrg/wlc/pull/1097CVE reference · x_refsource_MISC
- https://github.com/WeblateOrg/wlc/commit/a513864ec4daad00146e6d6e039559726e256fa3CVE reference · x_refsource_MISC
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Certificate Validation
Improper Certificate Validation represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
