LiveActive security incident?Get immediate response
CVE Record

CVE-2026-21896: Kirby is missing permission checks in the content changes API

Kirby is an open-source content management system. From versions 5.0.0 to 5.2.1, Kirby is missing permission checks in the content changes API. This vulnerability affects all Kirby sites where user permissions are configured to prevent specific role(s) from performing write actions, specifically by disabling the update permission with the intent to prevent modifications to site content. This vulnerability does not affect those who have not altered the deviated from default user permissions. This issue has been patched in version 5.2.2.

MediumCVSS 5.8Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-21896 lets certain logged-in Kirby CMS users change content even when their role was configured to block updates. The issue matters most for sites relying on custom role restrictions to protect editorial or site content. Kirby 5.2.2 patches it.

Executive priority

Address in the normal vulnerability remediation cycle, with higher priority for public or business-critical Kirby sites that rely on restricted editor roles. The main business risk is unauthorized content modification by authenticated users who should not have write access.

Technical view

Kirby versions 5.0.0 through 5.2.1 are missing authorization checks in the content changes API. The flaw is CWE-863, incorrect authorization. Scope is limited to Kirby sites with non-default permissions that disable update rights for specific roles. CVSS v4.0 score is 5.8.

Likely exposure

Exposure is likely only where Kirby 5.0.0 to 5.2.1 is deployed and user permissions were customized to prevent write or update actions for specific roles. Sites using default permissions are described as not affected by the advisory.

Exploitation context

The CVSS vector indicates network access, low attack complexity, low privileges, and user interaction required. The source bundle does not report active exploitation, and this CVE is not listed as KEV. Treat exploitation as plausible but not publicly confirmed from provided sources.

Researcher notes

The affected condition is narrower than a blanket Kirby compromise: vulnerable versions plus customized permissions blocking updates. The patch reference and 5.2.2 release are available, but the provided sources do not include public exploit details or evidence of exploitation in the wild.

Mitigation direction

  • Upgrade Kirby to version 5.2.2 or later.
  • Prioritize sites with custom roles that disable update permissions.
  • Review vendor advisory and release notes before deployment.
  • If immediate upgrade is delayed, review Kirby access controls with vendor guidance.

Validation and detection

  • Inventory Kirby sites and confirm running versions.
  • Identify sites using Kirby 5.0.0 through 5.2.1.
  • Review role configurations for disabled update permissions.
  • Confirm Kirby is upgraded to 5.2.2 or later.
  • Check content audit logs for unexpected changes by restricted users.
Prepared
Confidence
high
Sources
5

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-863: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-21896 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
5.8 (4.0)
Known Exploited
No
Published

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
4Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
5.8CVSS 4.0MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N——Primary CVE score

Vulnerability scoring details

Base CVSS 4.0 score

5.8Medium
CVSS 4.0 vector shape for CVE-2026-21896Attack VectorAttack ComplexityAttack RequirementsPrivileges RequiredUser InteractionVS ConfidentialityVS IntegrityVS AvailabilitySS ConfidentialitySS IntegritySS Availability

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Attack Requirements
NonePresent
Privileges Required
NoneLowHigh
User Interaction
NonePassiveActive
VS Confidentiality
HighLowNone
VS Integrity
HighLowNone
VS Availability
HighLowNone
SS Confidentiality
HighLowNone
SS Integrity
HighLowNone
SS Availability
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
getkirbykirby>= 5.0.0, < 5.2.2Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-863 · source CWE mapping

Incorrect Authorization

Incorrect Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.