LiveActive security incident?Get immediate response
CVE Record

CVE-2026-21873: Zero-click XSS in all NiceGUI apps which uses `ui.sub_pages`

NiceGUI is a Python-based UI framework. From versions 2.22.0 to 3.4.1, an unsafe implementation in the pushstate event listener used by ui.sub_pages allows an attacker to manipulate the fragment identifier of the URL, which they can do despite being cross-site, using an iframe. This issue has been patched in version 3.5.0.

HighCVSS 7.2Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

CVE-2026-21873 is a high-severity cross-site scripting flaw in NiceGUI applications using ui.sub_pages. A malicious site can manipulate a victim’s browser URL fragment through an iframe, triggering script execution without user interaction. Organizations running affected NiceGUI versions should prioritize upgrading to the patched release.

Executive priority

Treat as a near-term remediation item for any internet-facing NiceGUI application using ui.sub_pages. The issue requires no user interaction and can affect confidentiality and integrity, but availability impact is not indicated.

Technical view

NiceGUI versions 2.22.0 through 3.4.1 have an unsafe pushstate event listener implementation used by ui.sub_pages. The flaw enables zero-click XSS via URL fragment manipulation, including cross-site iframe scenarios. It is classified as CWE-79 with CVSS 3.1 score 7.2 and scope changed.

Likely exposure

Exposure is limited to applications built with NiceGUI versions >=2.22.0 and <3.5.0 that use ui.sub_pages. Publicly accessible applications increase business risk because attacks can originate from another site visited by users.

Exploitation context

The source bundle describes zero-click XSS and cross-site iframe-based URL fragment manipulation. It does not state active exploitation, and KEV is false. No public exploit status is established from the provided sources.

Researcher notes

Evidence comes from the CVE record and GitHub advisory. The vulnerable range and patched version are clear. The provided material does not include exploit code, reports of exploitation in the wild, or compensating controls beyond upgrading.

Mitigation direction

  • Upgrade NiceGUI to version 3.5.0 or later.
  • Identify applications using ui.sub_pages before prioritizing rollout.
  • Review vendor advisory and release notes for any additional guidance.
  • If immediate upgrade is delayed, assess exposure of affected applications.

Validation and detection

  • Inventory NiceGUI package versions across deployed applications.
  • Confirm affected applications use ui.sub_pages.
  • Verify NiceGUI is upgraded to 3.5.0 or later.
  • Review application security tests for reflected or DOM-based XSS coverage.
Prepared
Confidence
high
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-79: User-session and phishing behavior lookup

Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-21873 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
7.2 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
3Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
7.2CVSS 3.1HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N3.92.7Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

7.2High
CVSS 3.1 vector shape for CVE-2026-21873Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
zauberzeugnicegui>= 2.22.0, < 3.5.0Listed
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-79 · source CWE mapping

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.