LiveActive security incident?Get immediate response
CVE Record

CVE-2026-2020: JS Archive List <= 6.1.7 - Authenticated (Contributor+) PHP Object Injection via 'included' Shortcode Attribute

The JS Archive List plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 6.1.7 via the 'included' shortcode attribute. This is due to the deserialization of untrusted input supplied via the 'included' parameter of the plugin's shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

HighCVSS 7.5Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

CVE-2026-2020 affects the WordPress JS Archive List plugin through version 6.1.7. A logged-in user with Contributor or higher privileges can trigger unsafe PHP object deserialization through a shortcode attribute. The most severe outcomes require a compatible “POP chain” from another plugin or theme, which the source says is not present in JS Archive List itself.

Executive priority

Treat as a high-priority WordPress plugin issue where Contributor access is broadly available or sites run many third-party plugins. The risk is serious but conditional; prioritize inventory, access restriction, and update decisions over emergency incident response unless local evidence suggests abuse.

Technical view

The issue is CWE-502: deserialization of untrusted input in the plugin shortcode’s included attribute. CVSS is 7.5 High with network access, low privileges, no user interaction, and high attack complexity. Impact can include file deletion, sensitive data exposure, or code execution only if another installed component supplies a usable gadget chain.

Likely exposure

Exposure is limited to WordPress sites running JS Archive List version 6.1.7 or earlier, especially where Contributor-level accounts are available to untrusted users. Sites with many plugins or custom themes may have higher practical risk because exploitation depends on an external POP chain.

Exploitation context

The source bundle does not indicate active exploitation, and the CVE is not listed as KEV. Attackers need authenticated Contributor-or-higher access. The CVSS high attack complexity reflects the need for a suitable POP chain outside the vulnerable plugin for severe impact.

Researcher notes

Public sources identify unsafe deserialization through the included shortcode attribute. Wordfence states no known POP chain exists in the vulnerable plugin, so exploitability depends on other installed code. The Trac references and changeset should be reviewed to understand code-level remediation without assuming a fixed release not named in the sources.

Mitigation direction

  • Inventory WordPress sites for JS Archive List versions 6.1.7 or earlier.
  • Check vendor or WordPress plugin guidance for a fixed version after 6.1.7.
  • Update the plugin if a fixed release is available from trusted sources.
  • Restrict Contributor-level access to trusted users until remediation is complete.
  • Disable or remove the plugin where updates are unavailable and risk is unacceptable.
  • Review installed plugins and themes for added deserialization gadget-chain risk.

Validation and detection

  • Confirm the installed plugin slug and version on each WordPress site.
  • Verify whether any site runs JS Archive List 6.1.7 or earlier.
  • Review Contributor and higher accounts for unnecessary or untrusted access.
  • Check posts and pages for unexpected JS Archive List shortcode usage.
  • Review security logs for suspicious content edits by low-privileged users.
  • Document remediation status and remaining sites awaiting vendor guidance.
Prepared
Confidence
high
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-502: Code execution behavior lookup

Code execution and unsafe deserialization weaknesses often justify reviewing execution behavior and process telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-2020 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
7.5 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
7Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
7.5CVSS 3.1HighCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H1.65.9Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

7.5High
CVSS 3.1 vector shape for CVE-2026-2020Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
skatoxJS Archive List0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-502 · source CWE mapping

Deserialization of Untrusted Data

Deserialization of Untrusted Data represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.