LiveActive security incident?Get immediate response
CVE Record

CVE-2026-1926: Subscriptions for WooCommerce <= 1.9.2 - Missing Authorization to Unauthenticated Arbitrary Subscription Cancellation

The Subscriptions for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `wps_sfw_admin_cancel_susbcription()` function in all versions up to, and including, 1.9.2. This is due to the function being hooked to the `init` action without any authentication or authorization checks, and only performing a non-empty check on the nonce parameter without actually validating it via `wp_verify_nonce()`. This makes it possible for unauthenticated attackers to cancel any active WooCommerce subscription by sending a crafted GET request with an arbitrary nonce value via the `wps_subscription_id` parameter.

MediumCVSS 5.3Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-1926 lets an unauthenticated internet user cancel active WooCommerce subscriptions on sites using the Subscriptions for WooCommerce plugin through version 1.9.2. It does not expose customer data or provide site takeover, but it can disrupt recurring revenue, customer access, and support operations.

Executive priority

Prioritize for ecommerce sites with meaningful subscription revenue. This is not a critical takeover issue, but unauthorized cancellations can cause revenue loss, customer churn, and operational cleanup. Address during the next urgent WordPress maintenance window.

Technical view

The vulnerable function `wps_sfw_admin_cancel_susbcription()` lacks capability checks and is hooked to WordPress `init`. It checks that a nonce parameter is non-empty but does not validate it with `wp_verify_nonce()`. An unauthenticated request can target a subscription ID and trigger cancellation. CVSS 3.1 is 5.3, CWE-862.

Likely exposure

Public WordPress sites using Subscriptions for WooCommerce versions up to and including 1.9.2 are the primary exposure. Risk is higher where WooCommerce subscriptions directly control billing, entitlements, or customer access.

Exploitation context

The source bundle does not show CISA KEV listing or cited evidence of active exploitation. The vulnerability is remotely reachable, unauthenticated, low complexity, and requires no user interaction, but documented impact is limited to unauthorized subscription cancellation.

Researcher notes

Evidence points to missing authorization and ineffective nonce validation in a function registered on `init`. The referenced WordPress Trac changeset should be reviewed to understand the vendor-side code change. Do not assume broader data access or privilege escalation from the provided sources alone.

Mitigation direction

  • Identify all WordPress sites using Subscriptions for WooCommerce.
  • Upgrade beyond version 1.9.2 if a fixed vendor release is available.
  • If no fixed release is available, follow vendor guidance or temporarily disable the plugin.
  • Review business processes for restoring incorrectly cancelled subscriptions.
  • Restrict unnecessary public access to administrative or subscription-management endpoints where feasible.

Validation and detection

  • Check installed plugin version on each WordPress site.
  • Confirm whether version is 1.9.2 or earlier.
  • Review web logs for unexpected subscription-cancellation requests and affected subscription IDs.
  • Compare recent cancellations against customer, billing, and administrator activity.
  • Validate remediation by confirming the vulnerable code path is no longer present.
Prepared
Confidence
high
Sources
6

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-862: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-1926 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
5.3 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
7Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
5.3CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N3.91.4Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

5.3Medium
CVSS 3.1 vector shape for CVE-2026-1926Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
wpswingsSubscriptions for WooCommerce0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-862 · source CWE mapping

Missing Authorization

Missing Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.