CVE-2026-18937: Broken Link Checker < 2.4.12 - Unauthenticated RCE via Query Variable Injection
The Broken Link Checker WordPress plugin before 2.4.12 does not limit which query variables it accepts from user input on sites using plain permalinks, allowing unauthenticated users to overwrite arbitrary PHP global variables, and to execute arbitrary code on the server when a classic (non-block) is active.
Security readout for executives and security teams
Plain-English summary
A critical flaw in Broken Link Checker versions before 2.4.12 may let an unauthenticated internet user take control of a WordPress server. Exploitation requires plain permalinks and an additional classic, non-block component that the supplied description does not identify. Sites lacking those conditions may not be exploitable through this path.
Executive priority
Treat confirmed qualifying sites as an immediate remediation priority because successful exploitation could compromise the entire WordPress server and its data. Prioritize public-facing installations first. Do not claim compromise or active exploitation solely from this advisory; the supplied evidence supports serious potential impact, not observed attacks.
Technical view
On qualifying WordPress configurations, unrestricted query-variable handling permits unauthenticated input to overwrite arbitrary PHP global variables. The supplied record states this can lead to arbitrary code execution when plain permalinks and an incompletely identified classic, non-block component are active. CVSS 3.1 is 9.0, with high confidentiality, integrity, and availability impacts.
Likely exposure
Potentially exposed systems are internet-accessible WordPress sites running Broken Link Checker earlier than 2.4.12 with plain permalinks and the additional stated prerequisite. The source bundle does not clearly identify that prerequisite, and its structured affected-product data conflicts with the narrative version range, so exposure requires manual confirmation.
Exploitation context
The WPScan reference is tagged as containing exploit information, but the bundle provides no evidence of exploitation in the wild. The CVE is not listed as KEV in the supplied data. Attack complexity is rated high, although no privileges or user interaction are required once the necessary configuration exists.
Researcher notes
The narrative identifies versions before 2.4.12, but the structured affected entry lists version "0" with default status "unaffected." The description also omits the noun after “classic (non-block),” leaving a material exploit prerequisite unclear. Confirm both issues against the linked CVE and WPScan records before final exposure classification.
Mitigation direction
Upgrade Broken Link Checker to version 2.4.12 or later after confirming official release guidance.
Temporarily disable the plugin where rapid upgrading is impossible, subject to operational review.
Identify sites using plain permalinks and prioritize those systems for remediation.
Review the CVE and WPScan advisories for clarification of the missing configuration prerequisite.
Validation and detection
Inventory every WordPress installation and record its Broken Link Checker version.
Confirm whether each site uses plain permalinks.
Determine which classic, non-block component the advisory requires before declaring a site exposed.
Verify remediated sites run version 2.4.12 or later.
Review relevant server logs and recent file changes for unexpected activity.
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Potential ATT&CK relevance
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
cwe · medium confidence lookup
CWE-94: Code execution behavior lookup
Code execution and unsafe deserialization weaknesses often justify reviewing execution behavior and process telemetry. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
1CVSS vectors
3Timeline events
1ADP providers
2Source links
SSVC decision data
CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: noneAutomatable: noTechnical Impact: total
CVSS vector scores
1 official score
We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
CWE-94 · source CWE mapping
Improper Control of Generation of Code
Improper Control of Generation of Code represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.