Security readout for executives and security teams
Plain-English summary
CVE-2026-1706 affects the WordPress All-in-One Video Gallery plugin through version 4.7.1. A malicious link can cause script to run in a visitor’s browser if the visitor clicks it. This is not server takeover, but it can support phishing, session abuse, or content manipulation in the victim’s browser.
Executive priority
Treat as a routine but timely WordPress remediation. Prioritize public sites and sites used by privileged content managers. This is moderate business risk because it depends on user interaction, but successful abuse can damage trust or assist account-focused attacks.
Technical view
The flaw is reflected cross-site scripting in the plugin’s `vi` parameter, caused by insufficient input sanitization and output escaping. It is unauthenticated and network-reachable, but requires user interaction. The CVSS 3.1 score is 6.1, vector AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N, mapped to CWE-79.
Likely exposure
Public WordPress sites using All-in-One Video Gallery versions up to and including 4.7.1 are the likely exposure. Risk is higher where administrators, editors, or authenticated users may click externally supplied links while logged in.
Exploitation context
The provided sources do not show CISA KEV listing or active exploitation. Exploitation requires tricking a user into opening a crafted link. The impact is browser-side script execution, not direct server compromise.
Researcher notes
Wordfence reports reflected XSS via `vi`. The CVE references vulnerable code in 4.7.1 and a WordPress Trac changeset, but the provided bundle does not name a specific fixed release. Avoid claiming active exploitation without additional evidence.
Mitigation direction
- Identify WordPress sites using All-in-One Video Gallery.
- Upgrade beyond version 4.7.1 if a fixed vendor release is available.
- If no fixed release is available, follow vendor guidance before re-enabling exposure.
- Temporarily disable the plugin where business impact allows.
- Warn privileged WordPress users not to open untrusted plugin-related links.
Validation and detection
- Inventory plugin name and version across WordPress installations.
- Flag All-in-One Video Gallery versions 4.7.1 and earlier.
- Review vendor changelog or WordPress plugin updates for the fixing release.
- Confirm the site no longer runs the vulnerable version after remediation.
- Check web logs for unusual requests involving the `vi` parameter.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-79: User-session and phishing behavior lookup
Client-side and session-facing weaknesses should be reviewed alongside initial-access and user-execution behaviors. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupCVE-2026-1706 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- Medium
- CVSS
- 6.1 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N2.82.7Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
6.1MediumVector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Source materials
- CVE List V5 sourceCVE List V5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bcaff8ab-2db9-4d91-9b7a-f7f49f5952b9?source=cveCVE reference
- https://plugins.trac.wordpress.org/browser/all-in-one-video-gallery/tags/4.7.1/public/videos.php#L776CVE reference
- https://plugins.trac.wordpress.org/browser/all-in-one-video-gallery/tags/4.7.1/includes/helpers/render.php#L304CVE reference
- https://plugins.trac.wordpress.org/changeset/3469442/all-in-one-video-gallery/trunk/public/videos.phpCVE reference
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
