LiveActive security incident?Get immediate response
CVE Record

CVE-2026-1321: Membership Plugin – Restrict Content <= 3.2.20 - Unauthenticated Privilege Escalation via 'rcp_level'

The Membership Plugin – Restrict Content plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.2.20. This is due to the `rcp_setup_registration_init()` function accepting any membership level ID via the `rcp_level` POST parameter without validating that the level is active or that payment is required. Combined with the `add_user_role()` method which assigns the WordPress role configured on the membership level without status checks, this makes it possible for unauthenticated attackers to register with any membership level, including inactive levels that grant privileged WordPress roles such as Administrator, or paid levels that charge a sign-up fee. The vulnerability was partially patched in version 3.2.18.

HighCVSS 8.1Not KEV-listedUpdated
Glexia's TakeAutomated analysishigh

Security readout for executives and security teams

Plain-English summary

CVE-2026-1321 affects the WordPress Restrict Content membership plugin through version 3.2.20. An unauthenticated visitor may be able to register into a membership level that should be inactive or paid, potentially receiving the WordPress role tied to that level, including Administrator if misconfigured.

Executive priority

Treat as urgent for WordPress sites using this plugin. The business risk is account takeover or full site control if a membership level grants an administrative role. Prioritize internet-facing sites with registration enabled.

Technical view

The issue is missing authorization/status validation. rcp_setup_registration_init() accepts the rcp_level POST value without confirming the level is active or payment-gated. add_user_role() then assigns the WordPress role configured for that membership level without sufficient status checks. The CVE lists CVSS 8.1 and CWE-862.

Likely exposure

Exposure is likely on WordPress sites running Restrict Content versions up to and including 3.2.20, especially where public registration is enabled and membership levels map to elevated WordPress roles. Sites with inactive or paid levels granting privileged roles face higher impact.

Exploitation context

The source bundle does not show CISA KEV listing or confirmed active exploitation. Exploitation is unauthenticated but rated high complexity, likely depending on site configuration, available membership levels, and role mappings.

Researcher notes

Evidence comes from the CVE description, Wordfence entry, and WordPress Trac references. The vulnerability was partially patched in 3.2.18, but the CVE still lists versions through 3.2.20 as affected. No active exploitation is established in the provided sources.

Mitigation direction

  • Update Restrict Content to the latest available version newer than 3.2.20, if provided by the vendor.
  • Review vendor and Wordfence guidance before assuming partial fixes fully address the issue.
  • Disable or restrict public registration until patched and validated.
  • Remove privileged WordPress roles from membership levels unless strictly required.
  • Audit inactive and paid membership levels for dangerous role assignments.

Validation and detection

  • Inventory all WordPress sites using the Restrict Content plugin.
  • Confirm installed plugin versions are not 3.2.20 or earlier.
  • Review membership levels for Administrator or other elevated role mappings.
  • Check recent registrations for unexpected elevated WordPress roles.
  • Verify vendor changelog or Trac changes are present after updating.
Prepared
Confidence
high
Sources
9

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · medium confidence lookup

CWE-862: Authorization and privilege behavior lookup

Authorization weaknesses can support privilege escalation and valid-account review, depending on exploit path. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
description · low confidence lookup

Privilege behavior lookup

The CVE wording references privilege impact, so privilege escalation and authorization behavior review may help. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-1321 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
High
CVSS
8.1 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
7Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
8.1CVSS 3.1HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H2.25.9Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

8.1High
CVSS 3.1 vector shape for CVE-2026-1321Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
stellarwpMembership Plugin – Restrict Content0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-862 · source CWE mapping

Missing Authorization

Missing Authorization represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.