LiveActive security incident?Get immediate response
CVE Record

CVE-2026-1206: Elementor Website Builder <= 3.35.7 - Incorrect Authorization to Authenticated (Contributor+) Sensitive Information Exposure via Elementor Template

The Elementor Website Builder plugin for WordPress is vulnerable to Incorrect Authorization to Sensitive Information Exposure in all versions up to, and including, 3.35.7. This is due to a logic error in the is_allowed_to_read_template() function permission check that treats non-published templates as readable without verifying edit capabilities. This makes it possible for authenticated attackers, with contributor-level access and above, to read private or draft Elementor template content via the 'template_id' supplied to the 'get_template_data' action of the 'elementor_ajax' endpoint.

MediumCVSS 4.3Not KEV-listedUpdated
Glexia's TakeAutomated analysismoderate

Security readout for executives and security teams

Plain-English summary

CVE-2026-1206 lets a logged-in WordPress user with Contributor-level access or higher read private or draft Elementor template content. It is not a full site takeover issue, but it can expose unpublished page designs or sensitive content stored in templates. Public sources rate it medium severity.

Executive priority

Treat as a near-term maintenance and access-control issue, not an emergency unless many non-employee Contributor accounts exist. Prioritize public or partner-managed WordPress sites and sites where draft templates may contain confidential content.

Technical view

Elementor Website Builder for WordPress versions up to and including 3.35.7 has an incorrect authorization flaw in is_allowed_to_read_template(). Non-published templates can be treated as readable without verifying edit capability. An authenticated Contributor+ user can request template data through the elementor_ajax get_template_data action using a template_id.

Likely exposure

Exposure is mainly WordPress sites using Elementor up to 3.35.7 where untrusted or semi-trusted users have Contributor or higher accounts. Sites without such users have lower practical exposure, based on the published privilege requirement.

Exploitation context

The CVE requires network access and a valid authenticated WordPress account with Contributor-level privileges or above. Public sources provided do not indicate active exploitation, and the CVE is not listed as KEV in the supplied data.

Researcher notes

The issue maps to CWE-639 and CVSS 4.3, reflecting authenticated, low-privilege, confidentiality-only impact. The supplied WordPress Trac changeset is relevant patch evidence, but public sources here do not provide exploitation-in-the-wild evidence.

Mitigation direction

  • Update Elementor to a version newer than 3.35.7 when available from the vendor.
  • Review Elementor and WordPress.org plugin guidance for the patched release details.
  • Limit Contributor and higher accounts to trusted users only.
  • Remove stale WordPress accounts that no longer need access.
  • Avoid storing secrets or sensitive business data inside draft/private templates.

Validation and detection

  • Inventory WordPress sites using the Elementor Website Builder plugin.
  • Check installed Elementor versions and flag versions 3.35.7 or earlier.
  • Review whether Contributor or higher accounts exist on affected sites.
  • Confirm vendor patch adoption through plugin changelog or WordPress admin.
  • Audit sensitive draft/private Elementor templates for exposed content risk.
Prepared
Confidence
high
Sources
4

Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.

Potential ATT&CK relevance

Conservative CVE-to-ATT&CK context

These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.

ATT&CK lookup starting points

Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.

cwe · low confidence lookup

CWE-639: Exact CWE lookup

Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.

Open ATT&CK lookup
cve · low confidence lookup

CVE-2026-1206 mapping review

Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.

Open ATT&CK lookup
Vulnerability profileCVE Program record
Severity
Medium
CVSS
4.3 (3.1)
Known Exploited
No
Published

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Official CVE source material

CNA and ADP enrichment extracted from CVE v5

These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.

1CVSS vectors
0Timeline events
0ADP providers
3Source links

CVSS vector scores

1 official score

We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.

ScoreVersionSeverityVectorExploitImpactSource
4.3CVSS 3.1MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N2.81.4Primary CVE score

Vulnerability scoring details

Base CVSS 3.1 score

4.3Medium
CVSS 3.1 vector shape for CVE-2026-1206Attack VectorAttack ComplexityPrivileges RequiredUser InteractionScopeConfidentiality ImpactIntegrity ImpactAvailability Impact

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Attack Vector
NetworkAdjacentLocalPhysical
Attack Complexity
LowHigh
Privileges Required
NoneLowHigh
User Interaction
NoneRequired
Scope
ChangedUnchanged
Confidentiality Impact
HighLowNone
Integrity Impact
HighLowNone
Availability Impact
HighLowNone
Affected products

Products and packages named in the record

VendorProductVersion / packageStatus
elemntorElementor Website Builder – more than just a page builder0unaffected
Weakness

CWE details

CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.

CWE-639 · source CWE mapping

Authorization Bypass Through User-Controlled Key

Authorization Bypass Through User-Controlled Key represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.