Security readout for executives and security teams
Plain-English summary
CVE-2026-0903 affects Google Chrome on Windows before 144.0.7559.59. A malicious file could bypass Chrome’s dangerous-file protections, increasing the chance a user downloads or opens risky content. It requires user interaction and is rated Medium by Chromium.
Executive priority
Treat this as a normal-priority browser patching item, not an emergency. The main business risk is users being less protected from malicious downloads until Chrome is updated.
Technical view
The issue is an inappropriate implementation in Chrome Downloads on Windows, mapped to CWE-20. CVSS 3.1 is 5.4 with network attack vector, low complexity, no privileges, and required user interaction. Reported impacts are low confidentiality and integrity impact, with no availability impact.
Likely exposure
Organizations with Windows endpoints running Chrome versions earlier than 144.0.7559.59 are the relevant exposure. Non-Windows Chrome exposure is not stated in the provided sources.
Exploitation context
A remote attacker would need to deliver a malicious file and convince a user to interact with it. The sources do not report active exploitation, and it is not listed as CISA KEV in the provided bundle.
Researcher notes
Public detail is limited. The Chromium issue reference may not expose full root cause details. Do not assume exploitability beyond the stated dangerous-file protection bypass requiring user interaction.
Mitigation direction
- Update Google Chrome on Windows to 144.0.7559.59 or later.
- Prioritize managed Windows endpoints where Chrome auto-update may be disabled or delayed.
- Check Google Chrome release guidance for any additional vendor instructions.
Validation and detection
- Inventory Windows endpoints running Google Chrome.
- Confirm Chrome version is 144.0.7559.59 or later.
- Review browser management policies for blocked or delayed updates.
- Monitor download-related security alerts for suspicious file handling.
Public sources used
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
CWE-20: Exact CWE lookup
Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
Open ATT&CK lookupCVE-2026-0903 mapping review
Open the CVE-to-ATT&CK bridge for reviewed, inferred, or future official mappings tied to this CVE.
Open ATT&CK lookup- Severity
- Medium
- CVSS
- 5.4 (3.1)
- Known Exploited
- No
- Published
Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
CNA and ADP enrichment extracted from CVE v5
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
CVSS vector scores
1 official scoreWe collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N2.82.5Primary CVE scoreVulnerability scoring details
Base CVSS 3.1 score
5.4MediumVector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Source materials
Products and packages named in the record
CWE details
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
Improper Input Validation
Improper Input Validation represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.
