CVE-2022-51000: Nokogiri before 1.13.2 Multiple Vulnerabilities via libxml2 libxslt
Nokogiri before 1.13.2 (CRuby, when using packaged libraries) ships vendored libxml2 2.9.12 and libxslt 1.1.34, which are affected by two upstream CVEs. Via CVE-2021-30560 in libxslt, an application transforming XML with untrusted XSL stylesheets is vulnerable to a denial-of-service attack. Via CVE-2022-23308 in libxml2, an application parsing an untrusted document with parse option DTDVALID set to true and NOENT set to false may be vulnerable to denial of service, memory disclosure, or code execution. Nokogiri 1.13.2 upgrades vendored libxml2 to 2.9.13 and libxslt to 1.1.35.
Security readout for executives and security teams
Plain-English summary
CRuby applications using Nokogiri’s packaged libraries before version 1.13.2 may be exposed when processing attacker-controlled XML or XSLT. Depending on the processing path, an attacker could crash the service, disclose memory, or potentially execute code. The most severe outcome requires specific XML parser options; ordinary Nokogiri installation alone does not prove exploitability.
Executive priority
Treat exposed services as urgent because successful exploitation could affect confidentiality and availability, with possible code execution. Accelerate upgrades where untrusted XML or XSLT is processed. For applications lacking those paths or parser settings, confirm configuration promptly and schedule remediation based on verified exposure rather than CVSS alone.
Technical view
Affected releases vendor libxml2 2.9.12 and libxslt 1.1.34. Untrusted XSL stylesheets can trigger the CVE-2021-30560 denial-of-service condition. Untrusted documents may trigger CVE-2022-23308 when DTDVALID is true and NOENT is false, potentially causing denial of service, memory disclosure, or code execution. Nokogiri 1.13.2 updates both libraries.
Likely exposure
Prioritize internet-facing or multi-tenant CRuby services running Nokogiri before 1.13.2 with packaged libraries. Practical exposure depends on whether applications transform untrusted XSL stylesheets or parse untrusted documents using the specified DTDVALID and NOENT settings. Deployments using other library arrangements are not established as affected by this source bundle.
Exploitation context
The supplied CVSS score is 9.8, reflecting the potential unauthenticated remote impact. However, exploitation is conditional on attacker-controlled XML or XSLT reaching vulnerable operations. The bundle reports no CISA KEV listing and provides no evidence of active exploitation. Public proof-of-concept availability is not established by the supplied sources.
Researcher notes
This CVE aggregates two vulnerabilities in Nokogiri’s vendored dependencies and identifies CWE-416. Separate the XSLT denial-of-service path from the conditional libxml2 path during analysis. The bundle does not establish exploit reliability, observed attacks, or impact outside CRuby packaged-library builds. Validate actual dependency linkage and application-controlled parser options before declaring a deployment exploitable.
Mitigation direction
Upgrade affected Nokogiri installations to version 1.13.2 or later.
Confirm the deployed build uses the updated vendored libxml2 and libxslt versions.
Restrict or reject untrusted XML and XSLT processing until upgrades are complete.
Avoid the vulnerable parser-option combination when processing untrusted documents.
Check current Nokogiri vendor guidance before selecting compensating controls.
Validation and detection
Inventory deployed Nokogiri versions from application dependency manifests and runtime environments.
Determine whether each deployment is CRuby using Nokogiri packaged libraries.
Trace whether untrusted input can reach XML parsing or XSLT transformation.
Review parser configuration for DTDVALID true with NOENT false.
Verify upgraded deployments contain libxml2 2.9.13 and libxslt 1.1.35.
Generated from the cited source records. This long-tail analysis has not been individually reviewed by a named human.
Potential ATT&CK relevance
Conservative CVE-to-ATT&CK context
These mappings and lookup hints may be relevant to the vulnerability behavior, CWE, affected product, or exposure path. Glexia-inferred context is not an official MITRE, ATT&CK, CWE, or CVE Program mapping.
ATT&CK lookup starting points
Use these exact CWE pages and searches to review the Glexia ATT&CK library from this CVE's weakness and description context.
cwe · low confidence lookup
CWE-416: Exact CWE lookup
Use the exact CWE identifier as the starting point before reviewing related ATT&CK behavior. Open the exact CWE lookup page first, then review the ATT&CK searches from that MITRE weakness context. This is a Glexia lookup hint, not an official ATT&CK mapping.
The CVE wording references code or command execution, so execution technique review may help defensive triage. This is a Glexia inferred lookup path, not an official MITRE, ATT&CK, or CVE Program mapping.
These fields come from the CVE record and ADP containers, not from Glexia's Take. They preserve time-varying source decisions such as CISA SSVC, KEV status, CVSS metrics, and provider references.
2CVSS vectors
3Timeline events
1ADP providers
5Source links
SSVC decision data
CISA-ADPCISA Coordinator
Timestamp
Version
2.0.3
Exploitation: noneAutomatable: yesTechnical Impact: total
CVSS vector scores
2 official scores
We collect every scored CVSS vector available in the official CNA and ADP containers. When more than one version is present, the table keeps the source vectors side by side instead of collapsing them into the highest score.
CWE links open Glexia weakness intelligence pages with official CWE context, developer remediation guidance, and related CVE mappings.
CWE-416 · source CWE mapping
Use After Free
Use After Free represents a recurring weakness pattern that can create exploitable paths when design, validation, or implementation controls are missing.